aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2015-01-13 19:54:03 +0800
committermadpilot <madpilot@FreeBSD.org>2015-01-13 19:54:03 +0800
commit198aeee45c6f61ff8633bdd6036ddbcae450dc8d (patch)
treec1efa38a45429645001161f42eac06174bfca335
parent0aea06428b8756acc9a215bac670b6b49b8e2516 (diff)
downloadfreebsd-ports-gnome-198aeee45c6f61ff8633bdd6036ddbcae450dc8d.tar.gz
freebsd-ports-gnome-198aeee45c6f61ff8633bdd6036ddbcae450dc8d.tar.zst
freebsd-ports-gnome-198aeee45c6f61ff8633bdd6036ddbcae450dc8d.zip
- Make pjsip use ports provided libsrtp instead of boudled one
- Fix asterisk13 SRTP support - Fix asterisk13 SPEEX_LIB_DEPENDS - While here make SRTP option default for asterisk13 since it does not add dependencies
-rw-r--r--net/asterisk13/Makefile13
-rw-r--r--net/pjsip/Makefile5
-rw-r--r--net/pjsip/pkg-plist3
3 files changed, 13 insertions, 8 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index fbe67cd5e21d..625b637b5778 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,7 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -47,7 +47,7 @@ CONFLICTS_INSTALL= asterisk*-1.8* asterisk*-11*
OPTIONS_DEFINE= VORBIS PGSQL MYSQL ODBC RADIUS SNMP FREETDS XMPP SQLITE GSM \
CURL SPANDSP EXCHANGE NEWG711 SRTP LUA LDAP OOH323 PJSIP SPEEX
OPTIONS_DEFAULT= VORBIS ODBC PGSQL RADIUS SNMP FREETDS \
- XMPP GSM SQLITE3 CURL LUA PJSIP SPEEX
+ XMPP GSM SQLITE3 CURL SRTP LUA PJSIP SPEEX
OPTIONS_DEFINE_i386= DAHDI
OPTIONS_DEFINE_amd64= DAHDI
@@ -105,7 +105,6 @@ SPANDSP_LIB_DEPENDS= libspandsp.so:${PORTSDIR}/comms/spandsp
EXCHANGE_CONFIGURE_OFF= --without-neon --without-neon29
EXCHANGE_LIB_DEPENDS= libneon.so:${PORTSDIR}/www/neon
SRTP_CONFIGURE_WITH= srtp
-SRTP_BUILD_DEPENDS= libsrtp>=1.4.4:${PORTSDIR}/net/libsrtp
LUA_CONFIGURE_WITH= lua
LUA_USES= lua:51
LUA_CFLAGS= -I${LUA_INCDIR}
@@ -115,7 +114,7 @@ LDAP_USE= OPENLDAP=yes
PJSIP_LIB_DEPENDS= libpj.so:${PORTSDIR}/net/pjsip
PJSIP_CONFIGURE_WITH= pjproject
PJSIP_USES= pkgconfig
-SPEEX_LIB_DEPENDS= libspeexdsp.so:${PORTSDIR}/audio/speex
+SPEEX_LIB_DEPENDS= libspeex.so:${PORTSDIR}/audio/speex
SPEEX_CONFIGURE_WITH= speex
ASTERISK_USER?= asterisk
@@ -124,6 +123,12 @@ ASTERISK_GROUP?= asterisk
USERS= ${ASTERISK_USER}
GROUPS= ${ASTERISK_GROUP} dahdi
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MPJSIP} && ${PORT_OPTIONS:MSRTP}
+LIB_DEPENDS+= libsrtp.so:${PORTSDIR}/net/libsrtp
+.endif
+
.include <bsd.port.pre.mk>
.if ${PREFIX} == ${LOCALBASE}
diff --git a/net/pjsip/Makefile b/net/pjsip/Makefile
index fab697fb4f63..f6ca38c8df30 100644
--- a/net/pjsip/Makefile
+++ b/net/pjsip/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pjsip
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.pjsip.org/release/${PORTVERSION}/
DISTNAME= pjproject-${DISTVERSION}
@@ -11,10 +12,12 @@ COMMENT= Multimedia communication library written in C language
LICENSE= GPLv2
-LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2
+LIB_DEPENDS= libportaudio.so.2:${PORTSDIR}/audio/portaudio2 \
+ libsrtp.so:${PORTSDIR}/net/libsrtp
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-external-pa \
+ --with-external-srtp \
--disable-silk
USES= gmake tar:bz2
USE_LDCONFIG= yes
diff --git a/net/pjsip/pkg-plist b/net/pjsip/pkg-plist
index 10f21f23e85a..bb1dc31721ea 100644
--- a/net/pjsip/pkg-plist
+++ b/net/pjsip/pkg-plist
@@ -342,7 +342,4 @@ lib/libpjsua2-%%CONFIGURE_TARGET%%.a
%%NO_SAMPLERATE%%%%RESAMPLE%%lib/libresample-%%CONFIGURE_TARGET%%.a
%%NO_SAMPLERATE%%%%RESAMPLE%%%%RESAMPLEDLL%%lib/libresample.so
%%NO_SAMPLERATE%%%%RESAMPLE%%%%RESAMPLEDLL%%lib/libresample.so.2
-lib/libsrtp-%%CONFIGURE_TARGET%%.a
-%%SHARED%%lib/libsrtp.so
-%%SHARED%%lib/libsrtp.so.2
libdata/pkgconfig/libpjproject.pc