aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2013-07-10 21:42:41 +0800
committertobez <tobez@FreeBSD.org>2013-07-10 21:42:41 +0800
commit1cb3951367a9d2c956689be97b98129510fc47ef (patch)
tree25fb05de33b98c2d669aac74d345ad05983d6ebb
parentb0c75a5076a8ccb547d557ee18752d2c533bcb3e (diff)
downloadfreebsd-ports-gnome-1cb3951367a9d2c956689be97b98129510fc47ef.tar.gz
freebsd-ports-gnome-1cb3951367a9d2c956689be97b98129510fc47ef.tar.zst
freebsd-ports-gnome-1cb3951367a9d2c956689be97b98129510fc47ef.zip
Make it package correctly on clang-only boxes.
PR: 180220 Submitted by: Dave Hayes <dave@jetcafe.org>
-rw-r--r--net-mgmt/p5-NetAddr-IP/Makefile1
-rw-r--r--net-mgmt/p5-NetAddr-IP/files/patch-Lite-Util-Makefile.PL11
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/p5-NetAddr-IP/Makefile b/net-mgmt/p5-NetAddr-IP/Makefile
index 8a6997aff309..46b4c7d6efd0 100644
--- a/net-mgmt/p5-NetAddr-IP/Makefile
+++ b/net-mgmt/p5-NetAddr-IP/Makefile
@@ -3,6 +3,7 @@
PORTNAME= NetAddr-IP
PORTVERSION= 4.069
+PORTREVISION= 1
CATEGORIES= net-mgmt perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net-mgmt/p5-NetAddr-IP/files/patch-Lite-Util-Makefile.PL b/net-mgmt/p5-NetAddr-IP/files/patch-Lite-Util-Makefile.PL
new file mode 100644
index 000000000000..1a8f900e3d28
--- /dev/null
+++ b/net-mgmt/p5-NetAddr-IP/files/patch-Lite-Util-Makefile.PL
@@ -0,0 +1,11 @@
+--- ./Lite/Util/Makefile.PL.orig 2013-07-10 15:38:50.000000000 +0200
++++ ./Lite/Util/Makefile.PL 2013-07-10 15:38:55.000000000 +0200
+@@ -205,7 +205,7 @@ sub test_cc {
+ return;
+ }
+
+- my $CC = $ENV{CC} || $Config{ccname};
++ my $CC = $ENV{CC} || $Config{cc};
+ my $command = qq|$CC compile.c -o compile.output|;
+
+ print F <<'EOF';