aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2015-02-05 04:09:43 +0800
committercy <cy@FreeBSD.org>2015-02-05 04:09:43 +0800
commit1d939095f97a3344a6ae4b37abd01bbfa9f939ab (patch)
tree86cace4b5e422e4180d59beee9dca864290aa801
parent9cb53252878ebbac13eb0a50ff266cdee82245ae (diff)
downloadfreebsd-ports-gnome-1d939095f97a3344a6ae4b37abd01bbfa9f939ab.tar.gz
freebsd-ports-gnome-1d939095f97a3344a6ae4b37abd01bbfa9f939ab.tar.zst
freebsd-ports-gnome-1d939095f97a3344a6ae4b37abd01bbfa9f939ab.zip
Update 4.2.8 --> 4.2.8p1
-rw-r--r--net/ntp/Makefile5
-rw-r--r--net/ntp/distinfo4
-rw-r--r--net/ntp/files/patch-ntpd__ntp_io.c22
3 files changed, 4 insertions, 27 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index d7a667f458c8..2041f2f28bbd 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ntp
-PORTVERSION= 4.2.8
-PORTREVISION= 3
+PORTVERSION= 4.2.8p1
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ \
http://archive.ntp.org/ntp4/ntp-4.2/ \
@@ -47,7 +46,7 @@ CONFIGURE_ARGS+= --enable-${D}
.endif
.endfor
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}4
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}
# XXX Temporary hack. Remember to remove this next commit.
post-extract:
diff --git a/net/ntp/distinfo b/net/ntp/distinfo
index 5864086bd8f9..52716beec2b4 100644
--- a/net/ntp/distinfo
+++ b/net/ntp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ntp-4.2.8.tar.gz) = 2e920df8b6a5a410567a73767fa458c00c7f0acec3213e69ed0134414a50d8ee
-SIZE (ntp-4.2.8.tar.gz) = 6750364
+SHA256 (ntp-4.2.8p1.tar.gz) = 948274b88f1ed002d867ced6aaefdfd0999668b11285ac2b3a67ff2629d59d88
+SIZE (ntp-4.2.8p1.tar.gz) = 6791852
diff --git a/net/ntp/files/patch-ntpd__ntp_io.c b/net/ntp/files/patch-ntpd__ntp_io.c
deleted file mode 100644
index cf1486fa9252..000000000000
--- a/net/ntp/files/patch-ntpd__ntp_io.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ntpd/ntp_io.c.orig 2014-12-19 03:56:55.000000000 -0800
-+++ ntpd/ntp_io.c 2014-12-21 22:36:02.977441698 -0800
-@@ -3454,15 +3454,15 @@
- if (AF_INET6 == itf->family) {
- DPRINTF(1, ("Got an IPv6 packet, from <%s> (%d) to <%s> (%d)\n",
- stoa(&rb->recv_srcadr),
-- IN6_IS_ADDR_LOOPBACK(&rb->recv_srcadr),
-+ IN6_IS_ADDR_LOOPBACK(&rb->recv_srcadr.sa6.sin6_addr),
- stoa(&itf->sin),
-- !IN6_IS_ADDR_LOOPBACK(&itf->sin)
-+ !IN6_IS_ADDR_LOOPBACK(&itf->sin.sa6.sin6_addr)
- ));
- }
-
- if ( AF_INET6 == itf->family
-- && IN6_IS_ADDR_LOOPBACK(&rb->recv_srcadr)
-- && !IN6_IS_ADDR_LOOPBACK(&itf->sin)
-+ && IN6_IS_ADDR_LOOPBACK(&rb->recv_srcadr.sa6.sin6_addr)
-+ && !IN6_IS_ADDR_LOOPBACK(&itf->sin.sa6.sin6_addr)
- ) {
- packets_dropped++;
- DPRINTF(1, ("DROPPING that packet\n"));