aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-07 05:50:54 +0800
committerwill <will@FreeBSD.org>2000-06-07 05:50:54 +0800
commit1dc9e291f294010b3d100234e9af40677b04a346 (patch)
treeb5366d92e4112ce660672734ca636cfa8856d49c
parent47cf5c1af880bb924155def917dfcd1b3e284e5a (diff)
downloadfreebsd-ports-gnome-1dc9e291f294010b3d100234e9af40677b04a346.tar.gz
freebsd-ports-gnome-1dc9e291f294010b3d100234e9af40677b04a346.tar.zst
freebsd-ports-gnome-1dc9e291f294010b3d100234e9af40677b04a346.zip
Import new BSDI Netscape 4.73 (Communicator, non-crypto). This port's
history is preserved by repo-copy from www/netscape47-communicator. PR: 18595 Submitted by: Trevor Johnson <trevor@jpj.net>
-rw-r--r--www/bsdi-netscape47-communicator/Makefile49
-rw-r--r--www/bsdi-netscape47-communicator/files/mailcap69
-rw-r--r--www/bsdi-netscape47-communicator/pkg-comment2
-rw-r--r--www/bsdi-netscape47-communicator/pkg-descr23
-rw-r--r--www/bsdi-netscape47-communicator/pkg-plist20
5 files changed, 121 insertions, 42 deletions
diff --git a/www/bsdi-netscape47-communicator/Makefile b/www/bsdi-netscape47-communicator/Makefile
index 15d74d08869a..c431e6a4f258 100644
--- a/www/bsdi-netscape47-communicator/Makefile
+++ b/www/bsdi-netscape47-communicator/Makefile
@@ -1,37 +1,44 @@
-# New ports collection makefile for: netscape (communicator suite)
-# Date created: 24 Feb 1997
-# Whom: thepish
+# New ports collection makefile for: Netscape Communicator for BSDI BSD/OS
+# Date created: 10 May 2000
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on work by thepish and girgen@partitur.se
#
# $FreeBSD$
#
-PORTNAME?= netscape-${BROWSER_ARC}
-PORTVERSION?= ${BROWSER_VER}
+PORTNAME= bsdi-netscape-${BROWSER}
+PORTVERSION= ${BROWSER_VER}
+CATEGORIES= www
-.if !defined(_PREMKINCLUDED)
-.include <bsd.port.pre.mk>
+.if !defined(MASTER_SITES)
+MASTER_SITES= ftp://ftp.netscape.com/pub/communicator/english/4.73/unix/unsupported/bsdi21/complete_install/ \
+ ftp://ftp.sunet.se/pub/www/Netscape/communicator/english/4.73/unix/unsupported/bsdi21/complete_install/
.endif
-.if ${ARCH} == "i386"
-MASTER_SITES?= ftp://ftp.netscape.com./pub/communicator/english/4.73/unix/unsupported/freebsd/complete_install/
-DISTFILES?= communicator-v473-export.x86-unknown-freebsd.tar.gz
-.elif ${ARCH} == "alpha"
-MASTER_SITES?= ftp://ftp.netscape.com./pub/communicator/english/4.73/unix/supported/dec_unix40/complete_install/
-DISTFILES?= communicator-v473-export.alpha-dec-osf4.0.tar.gz
-.endif
+DISTFILES= ${BROWSER}-v473-export.x86-bsdi-bsd2.tar.gz
+
+MAINTAINER= trevor@jpj.net
+
+RUN_DEPENDS= netscape:${PORTSDIR}/www/netscape-wrapper
+
+ONLY_FOR_ARCHS= i386
-ONLY_FOR_ARCHS= i386 alpha
+# don't overwrite the FreeBSD port's shell script wrapper in ${PREFIX}/bin
+BROWSER_ARC= ${BROWSER}-bsdi
MASTERDIR= ${.CURDIR}/../netscape4-communicator
-.if ${ARCH} == "i386"
-WRKSRC?= ${WRKDIR}/${BROWSER}-v473.x86-unknown-freebsd
-.elif ${ARCH} == "alpha"
-WRKSRC?= ${WRKDIR}/${BROWSER}-v473.alpha-dec-osf4.0
-.endif
+WRKSRC= ${WRKDIR}/${BROWSER}-v473.x86-bsdi-bsd2
BROWSER_VER= 4.73
+# taken from ,${BLDVERS} in ns-install
INFILE_HEAD?= 'Communicator,4.73.0.20000502'
NO_AUTOADMIN= yes
-NO_FORTIFY= 'Not available for current version'
+
+MAILCAP= ${.CURDIR}/../bsdi-netscape47-communicator/files/mailcap
+NSUBDIR= lib/netscape-bsdi
+
+PRE_MK_INCLUDED= yes
+# don't require a.out libraries
+WITHOUT_AOUT= yes
.include "${MASTERDIR}/Makefile"
diff --git a/www/bsdi-netscape47-communicator/files/mailcap b/www/bsdi-netscape47-communicator/files/mailcap
new file mode 100644
index 000000000000..802c857cad5b
--- /dev/null
+++ b/www/bsdi-netscape47-communicator/files/mailcap
@@ -0,0 +1,69 @@
+# Example .mailcap file for FreeBSD machines
+#
+# First a note about syntax:
+# The first token in a configuration line represents a mime type.
+# A mime type is of the form "SubGroup/Item" and either token
+# can be replaced by the wildcard character "*"
+#
+# the second token is the command that you would run
+# when the specified mime type is encountered. An example
+# would be "xv %s" where %s will be replaced by a filename
+#
+# remaining tokens represent name value pairs.
+#
+# the "test=<SOME TEST COMMAND>" pair invokes the test command
+# specified and checks the UNIX shell return code to see if the
+# test passed. If the test passes the mime mapping is made, otherwise
+# the mapping is not made.
+#
+# the "stream-buffer-size=<NUMBER>" pair tells the application
+# to use a popen command to invoke the program specified and to
+# pipe all data into the command. Only programs that can handle
+# piped input can use this method. When this method is used
+# a "%s" should not be included in the command. You should
+# make sure that the program you wish to use can accept piped
+# data by trying something like this before using it:
+# cat "YOUR_DATA_FILE_HERE" | COMMAND_TO_TEST
+#
+# You may continue lines by using the backslash character "\"
+
+# FreeBSD doesn't seem to support `sfplay' yet, but if a port comes
+# along then the following should be enabled.
+#
+# plays AIFF files
+#audio/x-aiff; sfplay %s
+
+# plays AIFC files
+#audio/x-aifc; sfplay %s
+
+# FreeBSD has no wavplay utility either, but if someone
+# would care to port one then this can also be used.
+# plays WAV files
+#audio/x-wav; wavplay %s > /dev/null 2>&1
+
+# FreeBSD /dev/audio is sun compliant
+audio/basic; cat %s > /dev/audio
+
+# use this to play MPEG audio if you have maplay installed
+audio/x-mpeg; maplay -; stream-buffer-size=2000
+
+# use this to play MPEG video files if you have mpeg_play installed
+video/mpeg; mpeg_play -quiet %s
+
+# All other anims go well with xanim (if installed)
+video/*; xanim %s > /dev/null 2>&1
+
+# use this to display postscript files
+application/postscript; ghostview %s
+
+# use this to display pdf files
+application/pdf; acroread %s 2>/dev/null
+
+# this is the default for non GIF or JPEG images
+image/*; xv %s
+
+# if you would prefer an external viewer for GIF and JPEG images
+# uncomment the following lines for XV to act as your external viewer.
+#image/gif; xv %s
+#image/jpg; xv %s
+#image/jpeg; xv %s
diff --git a/www/bsdi-netscape47-communicator/pkg-comment b/www/bsdi-netscape47-communicator/pkg-comment
index 87c288818755..e04f060a37d7 100644
--- a/www/bsdi-netscape47-communicator/pkg-comment
+++ b/www/bsdi-netscape47-communicator/pkg-comment
@@ -1 +1 @@
-Netscape ver 4 communicator web-surfboard
+Communicator 4.73 browser, editor, mail and news for BSD/OS
diff --git a/www/bsdi-netscape47-communicator/pkg-descr b/www/bsdi-netscape47-communicator/pkg-descr
index e0a83b68e9ae..a93297852712 100644
--- a/www/bsdi-netscape47-communicator/pkg-descr
+++ b/www/bsdi-netscape47-communicator/pkg-descr
@@ -1,8 +1,15 @@
-This is the netscape web-surfboard. Please read the file
-"/usr/local/lib/netscape/LICENSE" for the licensing terms.
-
-Note: If Java applets fail to display. Type this as root:
- cd /usr/X11R6/lib/X11/fonts/misc
- /usr/X11R6/bin/mkfontdir
- chmod 444 fonts.dir
- And then exit and restart your X server.
+This is the BSDI BSD/OS version of the Netscape Communicator suite
+(Navigator Web browser, Messenger e-mail and news reader, and
+Composer HTML editor).
+
+Unlike the FreeBSD version, this does not require a.out X libraries.
+
+If Java applets fail to display, do this:
+
+ # cd /usr/X11R6/lib/X11/fonts/misc
+ # /usr/X11R6/bin/mkfontdir
+ # chmod 444 fonts.dir
+
+then exit and restart your X server.
+
+Please read /usr/local/lib/netscape/LICENSE.
diff --git a/www/bsdi-netscape47-communicator/pkg-plist b/www/bsdi-netscape47-communicator/pkg-plist
index 01e589b96796..967129981cd6 100644
--- a/www/bsdi-netscape47-communicator/pkg-plist
+++ b/www/bsdi-netscape47-communicator/pkg-plist
@@ -54,6 +54,14 @@ bin/%%BROWSER%%-%%BROWSER_VER%%
%%NSUBDIR%%/java/classes/hpux/font.properties.zh_TW_CNS11643
%%NSUBDIR%%/java/classes/ifc11.jar
%%NSUBDIR%%/java/classes/iiop10.jar
+%%NSUBDIR%%/java/classes/jae40.jar
+%%NSUBDIR%%/java/classes/java40.jar
+%%NSUBDIR%%/java/classes/jio40.jar
+%%NSUBDIR%%/java/classes/joptio40.jar
+%%NSUBDIR%%/java/classes/jsd10.jar
+%%NSUBDIR%%/java/classes/ldap40.jar
+%%NSUBDIR%%/java/classes/resource.jar
+%%NSUBDIR%%/java/classes/scd10.jar
%%NSUBDIR%%/java/classes/irix/font.properties
%%NSUBDIR%%/java/classes/irix/font.properties.cs
%%NSUBDIR%%/java/classes/irix/font.properties.el
@@ -63,15 +71,6 @@ bin/%%BROWSER%%-%%BROWSER_VER%%
%%NSUBDIR%%/java/classes/irix/font.properties.zh_GB2312
%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_Big5
%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_CNS11643
-%%NSUBDIR%%/java/classes/jae40.jar
-%%NSUBDIR%%/java/classes/java40.jar
-%%NSUBDIR%%/java/classes/jio40.jar
-%%NSUBDIR%%/java/classes/joptio40.jar
-%%NSUBDIR%%/java/classes/jsd10.jar
-%%NSUBDIR%%/java/classes/ldap40.jar
-%%NSUBDIR%%/java/classes/resource.jar
-%%NSUBDIR%%/java/classes/scd10.jar
-%%NSUBDIR%%/libjsd.so.1.0
%%NSUBDIR%%/mailcap
%%NSUBDIR%%/movemail
%%NSUBDIR%%/nethelp/Back_dep.gif
@@ -173,13 +172,11 @@ bin/%%BROWSER%%-%%BROWSER_VER%%
%%NSUBDIR%%/nethelp/picsfail.htm
%%NSUBDIR%%/nethelp/picsfail.jar
%%NSUBDIR%%/plugins/cpPack1.jar
-%%NSUBDIR%%/plugins/libnullplugin.so
%%NSUBDIR%%/registry
%%NSUBDIR%%/spell/netscape.dic
%%NSUBDIR%%/spell/pen4s324.dat
%%NSUBDIR%%/vreg
@dirrm %%NSUBDIR%%/spell
-@dirrm %%NSUBDIR%%/plugins
@dirrm %%NSUBDIR%%/nethelp/netscape/trouble
@dirrm %%NSUBDIR%%/nethelp/netscape/shared
@dirrm %%NSUBDIR%%/nethelp/netscape/news
@@ -195,4 +192,3 @@ bin/%%BROWSER%%-%%BROWSER_VER%%
@dirrm %%NSUBDIR%%/java/classes/aix
@dirrm %%NSUBDIR%%/java/classes
@dirrm %%NSUBDIR%%/java
-@unexec rmdir %D/%%NSUBDIR%% 2>/dev/null || true