aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-10-28 07:36:31 +0800
committerjhale <jhale@FreeBSD.org>2014-10-28 07:36:31 +0800
commit1dd3a4be985aebb47eb47e68808c26100e3c4c06 (patch)
treea3f5adda91830dc14c255da0a5f14c4d9a103548
parente4186055eb3dfcf242ff0d5ce8653b2c5ea70055 (diff)
downloadfreebsd-ports-gnome-1dd3a4be985aebb47eb47e68808c26100e3c4c06.tar.gz
freebsd-ports-gnome-1dd3a4be985aebb47eb47e68808c26100e3c4c06.tar.zst
freebsd-ports-gnome-1dd3a4be985aebb47eb47e68808c26100e3c4c06.zip
- Fix stage-qa error where STAGEDIR was being referenced by the binary
by setting up MAKE_ENV instead of passing STAGEDIR through PREFIX - Respect CC, CFLAGS, LDFLAGS, and MAKE_JOBS - Strip binaries - Convert USE_BZIP2 to USES - Use options helpers (this also fixes a problem where LIB_DEPENDS was being over-ridden in the PDF option, effectively cancelling out the LIB_DEPENDS for the PS option) Note: Did not use <OPT>_CONFIGURE_ENABLE because the configure script only understands --disable-<feature> - Bump PORTREVISION PR: 194317 Approved by: olivierd (maintainer)
-rw-r--r--graphics/electrix/Makefile56
1 files changed, 20 insertions, 36 deletions
diff --git a/graphics/electrix/Makefile b/graphics/electrix/Makefile
index 3cadee573e41..508c9142bdff 100644
--- a/graphics/electrix/Makefile
+++ b/graphics/electrix/Makefile
@@ -2,7 +2,7 @@
PORTNAME= electrix
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics print
MASTER_SITES= SF/${PORTNAME:tl}/${PORTVERSION}
@@ -11,54 +11,38 @@ COMMENT= Application to view PDF files
LICENSE= GPLv2
-USES= pkgconfig desktop-file-utils python:2
-USE_BZIP2= yes
+USES= desktop-file-utils pkgconfig python:2 tar:bzip2
USE_GNOME= gtk20 glib20 intltool intlhack
-CONFIGURE_ARGS= --prefix=${STAGEDIR}${PREFIX}
+MAKE_ENV= DESTDIR="${STAGEDIR}" \
+ JOBS="${MAKE_JOBS_NUMBER}" \
+ LINKFLAGS="${LDFLAGS}"
-OPTIONS_DEFINE= DBUS NLS PDF PS
+OPTIONS_DEFINE= DBUS NLS PDF PS
OPTIONS_DEFAULT= DBUS PDF
+OPTIONS_SUB= yes
-PDF_DESC= Portable Document Format Support
-PS_DESC= PostScript Support
+DBUS_LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
+DBUS_CONFIGURE_OFF= --disable-dbus
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CONFIGURE_OFF= --disable-nls
-.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-.else
-CONFIGURE_ARGS+= --disable-dbus
-.endif
+PDF_LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
+PDF_CONFIGURE_OFF= --disable-pdf
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB= NLS=""
-USES+= gettext
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPDF}
-LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
-.else
-CONFIGURE_ARGS+= --disable-pdf
-.endif
-
-.if ${PORT_OPTIONS:MPS}
-LIB_DEPENDS+= libspectre.so:${PORTSDIR}/print/libspectre
-.else
-CONFIGURE_ARGS+= --disable-ps
-.endif
+PS_LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre
+PS_CONFIGURE_OFF= --disable-ps
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} waf configure \
- ${CONFIGURE_ARGS} && ${TRUE}
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf configure \
+ ${CONFIGURE_ARGS} && ${TRUE})
do-build:
- @cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} waf build && ${TRUE}
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf build && ${TRUE})
do-install:
- @cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} waf install && ${TRUE}
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} waf install && ${TRUE})
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/electrix
.include <bsd.port.mk>