aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-04-07 02:49:52 +0800
committermarino <marino@FreeBSD.org>2015-04-07 02:49:52 +0800
commit1e42efde59e25f81a7aa3af2b00a05d9c541a7e0 (patch)
tree7fc9a7cbd0fa0ce4a92bb47f9a4ea0b401a4967b
parentb76ac8e3e4097c9ab08f44699bb98c376977c4bd (diff)
downloadfreebsd-ports-gnome-1e42efde59e25f81a7aa3af2b00a05d9c541a7e0.tar.gz
freebsd-ports-gnome-1e42efde59e25f81a7aa3af2b00a05d9c541a7e0.tar.zst
freebsd-ports-gnome-1e42efde59e25f81a7aa3af2b00a05d9c541a7e0.zip
x11-toolkits/wxgtk30: Support c++11 over c++0x, plus DragonFly
The wxgtk30 port will use TR1 headers if the capability is detected. These TR1 functions were experimental and not included in the same form in the final c++11 standard. This patch forcibly disabled TR1 support, which requires the explicit setting of -std=c++11 in CXXFLAGS> A private "exp-run" was performed, all 62 ports dependent on wxgtk2 successfully built before and after after the patch was applied on two separate runs (FreeBSD 10 amd64 jail). While here, remove the incorrect $PTHREAD_LIB setting and let it default to -pthread. Also bring in the configure patch fragement from DragonFly. PR: 199177 Submitted by: marino Approved by: maintainer (Chris Hutchinson)
-rw-r--r--x11-toolkits/wxgtk30/Makefile3
-rw-r--r--x11-toolkits/wxgtk30/files/patch-configure44
-rw-r--r--x11-toolkits/wxgtk30/files/patch-setup.h.in20
3 files changed, 57 insertions, 10 deletions
diff --git a/x11-toolkits/wxgtk30/Makefile b/x11-toolkits/wxgtk30/Makefile
index 5265bf14ab7b..0e33c8767f8d 100644
--- a/x11-toolkits/wxgtk30/Makefile
+++ b/x11-toolkits/wxgtk30/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wx
PORTVERSION= 3.0.2
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11-toolkits
MASTER_SITES= SF/wxwindows/${PORTVERSION}
PKGNAMESUFFIX= 30-gtk2
@@ -39,6 +39,7 @@ CONFIGURE_ARGS= --with-libpng=sys\
CONFIGURE_ENV= X11BASE="${LOCALBASE}" \
ac_cv_header_sys_inotify_h=no
CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -std=c++11
LIBS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= GSTREAMER MSPACK NLS
diff --git a/x11-toolkits/wxgtk30/files/patch-configure b/x11-toolkits/wxgtk30/files/patch-configure
index 7c17546e421b..31664c2f3e1b 100644
--- a/x11-toolkits/wxgtk30/files/patch-configure
+++ b/x11-toolkits/wxgtk30/files/patch-configure
@@ -1,6 +1,15 @@
---- configure.orig 2011-12-15 01:42:11.000000000 +0700
-+++ configure 2012-05-15 22:49:14.000000000 +0700
-@@ -27119,6 +27119,7 @@
+--- configure.orig 2014-10-06 21:33:44 UTC
++++ configure
+@@ -3947,7 +3947,7 @@ case "${host}" in
+
+ DEFAULT_DEFAULT_wxUSE_MOTIF=1
+ ;;
+- *-*-freebsd*)
++ *-*-dragonfly*|*-*-freebsd*)
+ USE_BSD=1
+ USE_FREEBSD=1
+ $as_echo "#define __FREEBSD__ 1" >>confdefs.h
+@@ -21894,6 +21894,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
SEARCH_INCLUDE="\
@@ -8,16 +17,17 @@
/usr/local/include \
/usr/local/X11/include \
/usr/local/include/X11 \
-@@ -42877,7 +42878,7 @@
+@@ -31852,9 +31853,6 @@ $as_echo "$as_me: WARNING: BeOS threads
+ THREAD_OPTS="-pthreads $THREAD_OPTS"
fi
;;
- *-*-freebsd*)
+- *-*-freebsd*)
- THREAD_OPTS="-kthread lthread $THREAD_OPTS c_r"
-+ THREAD_OPTS="$PTHREAD_LIBS"
- ;;
+- ;;
*-*-darwin* | *-*-cygwin* )
THREAD_OPTS=""
-@@ -45535,7 +45536,7 @@
+ ;;
+@@ -33127,7 +33125,7 @@ else
fi
fi
fi
@@ -25,4 +35,20 @@
+OPTIMISE_CFLAGS=
if test "x$WXWIN_COMPATIBILITY_2_6" = "xyes"; then
- cat >>confdefs.h <<\_ACEOF
+ $as_echo "#define WXWIN_COMPATIBILITY_2_6 1" >>confdefs.h
+@@ -39390,6 +39388,7 @@ EOF
+ ;;
+
+ powerpc-apple-macos* | \
++ *-*-dragonfly* | \
+ *-*-freebsd* | *-*-openbsd* | *-*-netbsd* | *-*-gnu* | *-*-k*bsd*-gnu | \
+ *-*-mirbsd* | \
+ *-*-sunos4* | \
+@@ -39432,6 +39431,7 @@ EOF
+
+ case "${BAKEFILE_HOST}" in
+ *-*-linux* | *-*-freebsd* | *-*-openbsd* | *-*-netbsd* | \
++ *-*-dragonfly* | \
+ *-*-k*bsd*-gnu | *-*-mirbsd* | *-*-gnu* )
+ if test "x$SUNCXX" = "xyes"; then
+ SONAME_FLAG="-h "
diff --git a/x11-toolkits/wxgtk30/files/patch-setup.h.in b/x11-toolkits/wxgtk30/files/patch-setup.h.in
new file mode 100644
index 000000000000..3571a20c807e
--- /dev/null
+++ b/x11-toolkits/wxgtk30/files/patch-setup.h.in
@@ -0,0 +1,20 @@
+--- setup.h.in.orig 2014-10-06 21:33:44 UTC
++++ setup.h.in
+@@ -757,17 +757,14 @@
+ /*
+ * Define if your compiler has std::tr1::unordered_map
+ */
+-#undef HAVE_TR1_UNORDERED_MAP
+
+ /*
+ * Define if your compiler has std::tr1::unordered_set
+ */
+-#undef HAVE_TR1_UNORDERED_SET
+
+ /*
+ * Define if your compiler has <tr1/type_traits>
+ */
+-#undef HAVE_TR1_TYPE_TRAITS
+
+ /*
+ * Define if your compiler has <type_traits>