aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjedgar <jedgar@FreeBSD.org>2002-10-09 09:05:03 +0800
committerjedgar <jedgar@FreeBSD.org>2002-10-09 09:05:03 +0800
commit2054215bd2bdb5835730c9fa58e7eeca62a29e35 (patch)
tree500ee646ebebc6ed912a41e1d42965ebea923bc3
parent4133d4bb4718ad61a964f7ead11415e38c0a906d (diff)
downloadfreebsd-ports-gnome-2054215bd2bdb5835730c9fa58e7eeca62a29e35.tar.gz
freebsd-ports-gnome-2054215bd2bdb5835730c9fa58e7eeca62a29e35.tar.zst
freebsd-ports-gnome-2054215bd2bdb5835730c9fa58e7eeca62a29e35.zip
Update port to 1.0.0
-rw-r--r--editors/xenon/Makefile17
-rw-r--r--editors/xenon/distinfo2
-rw-r--r--editors/xenon/files/patch-ab10
3 files changed, 18 insertions, 11 deletions
diff --git a/editors/xenon/Makefile b/editors/xenon/Makefile
index 7c8c2b741a46..0b899d3c2a3a 100644
--- a/editors/xenon/Makefile
+++ b/editors/xenon/Makefile
@@ -6,22 +6,29 @@
#
PORTNAME= xenon
-PORTVERSION= 0.6.7
+PORTVERSION= 1.0.0
CATEGORIES= editors
-MASTER_SITES= ftp://ftp.proximity.com.au/pub/xenon/
+MASTER_SITES= http://sydney.proximity.com.au/~ben/xenon/dist/ \
+ ftp://yankee.proximitygroup.com/pub/xenon/
MAINTAINER= jedgar@FreeBSD.org
+USE_GMAKE= yes
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
+MAKEFILE= ${WRKSRC}/makefiles/Makefile.Linux
MAN1= xe.1
-pre-patch:
- @${CP} ${WRKSRC}/makefiles/Makefile.Linux ${WRKSRC}/makefiles/Makefile.FreeBSD
+FIX_FILES= Xe.h XeApp.h XeFontTable.C XeFontTable.h XeKeyTable.C \
+ XeKeyTable.h XeObjectTable.h
do-configure:
- @cd ${WRKSRC}; ${LN} -sf makefiles/Makefile.FreeBSD Makefile
+.for file in ${FIX_FILES}
+ @${REINPLACE_CMD} -e 's|#include <ext/|#include <|' \
+ -e 's|ulong|u_long|g' -e 's|uint|u_int|g' ${WRKSRC}/${file}
+.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xe ${PREFIX}/bin
diff --git a/editors/xenon/distinfo b/editors/xenon/distinfo
index 646b0b9a9139..e02f7498fc2c 100644
--- a/editors/xenon/distinfo
+++ b/editors/xenon/distinfo
@@ -1 +1 @@
-MD5 (xenon-0.6.7.tar.gz) = 66ac7e29b53cbf764d0be3d470a6b188
+MD5 (xenon-1.0.0.tar.gz) = de69fbb01f56fd9985fe26627bf0ef33
diff --git a/editors/xenon/files/patch-ab b/editors/xenon/files/patch-ab
index 9f2bccbb27c6..53d82910eefb 100644
--- a/editors/xenon/files/patch-ab
+++ b/editors/xenon/files/patch-ab
@@ -1,10 +1,10 @@
---- makefiles/Makefile.FreeBSD.orig Wed Feb 16 22:55:41 2000
-+++ makefiles/Makefile.FreeBSD Wed Feb 16 22:58:34 2000
+--- makefiles/Makefile.Linux.orig Sun Jul 29 17:28:57 2001
++++ makefiles/Makefile.Linux Tue Oct 8 20:50:18 2002
@@ -6,19 +6,19 @@
include makefiles/Makefile.common
--CC = c++
+-CC = g++
+CC = $(CXX)
#CC = /usr/local/bin/c++
@@ -20,8 +20,8 @@
-INCLUDES = -I$(XEINC)
-LIBS = -L/usr/X11R6/lib -lXpm -lX11
-+INCLUDES = -I$(XEINC) -I${X11BASE}/include
-+LIBS = -L${X11BASE}/lib -lXpm -lX11
++INCLUDES = -I$(XEINC) -I$(X11BASE)/include
++LIBS = -L$(X11BASE)/lib -lXpm -lX11
backup:
cd ..;tar -cvzf xenon.tar.gz $(BACKUP)