aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2018-05-12 00:13:49 +0800
committerkrion <krion@FreeBSD.org>2018-05-12 00:13:49 +0800
commit20aa99306c982c662add7fd490e11eaedb4dba98 (patch)
tree082c08c8d7cf4021b305198ac39cfc8e377319bc
parent9c09721f617a9dee49adcfaa4c4ddbb859a4bd27 (diff)
downloadfreebsd-ports-gnome-20aa99306c982c662add7fd490e11eaedb4dba98.tar.gz
freebsd-ports-gnome-20aa99306c982c662add7fd490e11eaedb4dba98.tar.zst
freebsd-ports-gnome-20aa99306c982c662add7fd490e11eaedb4dba98.zip
Add sysutils/mtm:
mtm is the Micro Terminal Multiplexer, a terminal multiplexer. It has four major features/princples: - Simplicity: there are three commands (change focus, split, close). There are no modes, no dozens of commands, no crazy feature list. - Compatibility: mtm emulates a classic ANSI text terminal. That means it should work out of the box on essentially all terminfo/termcap-based systems (even pretty old ones), without needing to install a new termcap entry. - Size mtm is small. The entire project is around 1000 lines of code. - Stability: mtm is "finished" as it is now. You don't need to worry about it changing on you unexpectedly. The only changes that can happen at this point are: - Bug fixes. - Translation improvements. - Accessibility improvements. - Fixes to keep it working on modern OSes. WWW: https://github.com/deadpixi/mtm PR: 228152 Submitted by: 0mp@FreeBSD.org Reviewed by: tobik
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mtm/Makefile30
-rw-r--r--sysutils/mtm/distinfo3
-rw-r--r--sysutils/mtm/files/patch-Makefile13
-rw-r--r--sysutils/mtm/files/patch-config.def.h20
-rw-r--r--sysutils/mtm/pkg-descr18
6 files changed, 85 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 330d4c861636..eeea9e1b1fb1 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -711,6 +711,7 @@
SUBDIR += msiklm
SUBDIR += msktutil
SUBDIR += msyslog
+ SUBDIR += mtm
SUBDIR += mtpfs
SUBDIR += mtxorbd
SUBDIR += multitail
diff --git a/sysutils/mtm/Makefile b/sysutils/mtm/Makefile
new file mode 100644
index 000000000000..e5c8812bb328
--- /dev/null
+++ b/sysutils/mtm/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= mtm
+DISTVERSION= g20180507
+CATEGORIES= sysutils
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Terminal multiplexer focued on simplicity, compatibility and stability
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/README.rst
+
+USES= ncurses
+
+USE_GITHUB= yes
+GH_ACCOUNT= deadpixi
+GH_TAGNAME= b861104
+
+PLIST_FILES= bin/mtm \
+ man/man1/mtm.1.gz
+
+MAKE_ARGS+= LIBS='-lutil -lncursesw'
+
+PORTDATA= mtm.ti
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/mtm.ti ${STAGEDIR}${DATADIR}/mtm.ti
+
+.include <bsd.port.mk>
diff --git a/sysutils/mtm/distinfo b/sysutils/mtm/distinfo
new file mode 100644
index 000000000000..d11532a11d93
--- /dev/null
+++ b/sysutils/mtm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526029385
+SHA256 (deadpixi-mtm-g20180507-b861104_GH0.tar.gz) = f6685a9d309760f044c8de041d848fa97aafbc43e28127da63ef9fcd31fc9bd5
+SIZE (deadpixi-mtm-g20180507-b861104_GH0.tar.gz) = 281687
diff --git a/sysutils/mtm/files/patch-Makefile b/sysutils/mtm/files/patch-Makefile
new file mode 100644
index 000000000000..9256f5e0895d
--- /dev/null
+++ b/sysutils/mtm/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig 2018-05-07 14:54:13 UTC
++++ Makefile
+@@ -16,8 +16,8 @@ config.h: config.def.h
+ cp -i config.def.h config.h
+
+ install: mtm
+- cp mtm $(DESTDIR)/bin
+- cp mtm.1 $(DESTDIR)/share/man/man1
++ ${BSD_INSTALL_PROGRAM} mtm $(DESTDIR)$(PREFIX)/bin
++ ${BSD_INSTALL_MAN} mtm.1 $(DESTDIR)$(PREFIX)/man/man1
+
+ install-terminfo: mtm.ti
+ tic -s -x mtm.ti
diff --git a/sysutils/mtm/files/patch-config.def.h b/sysutils/mtm/files/patch-config.def.h
new file mode 100644
index 000000000000..08d476f569d8
--- /dev/null
+++ b/sysutils/mtm/files/patch-config.def.h
@@ -0,0 +1,20 @@
+--- config.def.h.orig 2018-05-07 14:54:13 UTC
++++ config.def.h
+@@ -38,7 +38,7 @@
+
+ /* The path for the wide-character curses library. */
+ #ifndef NCURSESW_INCLUDE_H
+- #if defined(__APPLE__) || (defined(BSD) && !defined(__linux__))
++ #if defined(__APPLE__) || (defined(BSD) && !defined(__linux__)) || defined(__FreeBSD__)
+ #define NCURSESW_INCLUDE_H <curses.h>
+ #else
+ #define NCURSESW_INCLUDE_H <ncursesw/curses.h>
+@@ -50,6 +50,8 @@
+ #ifndef FORKPTY_INCLUDE_H
+ #if defined(__APPLE__) || (defined(BSD) && !defined(__linux__))
+ #define FORKPTY_INCLUDE_H <util.h>
++ #elif defined(__FreeBSD__)
++ #define FORKPTY_INCLUDE_H <libutil.h>
+ #else
+ #define FORKPTY_INCLUDE_H <pty.h>
+ #endif
diff --git a/sysutils/mtm/pkg-descr b/sysutils/mtm/pkg-descr
new file mode 100644
index 000000000000..1a3a56195542
--- /dev/null
+++ b/sysutils/mtm/pkg-descr
@@ -0,0 +1,18 @@
+mtm is the Micro Terminal Multiplexer, a terminal multiplexer.
+
+It has four major features/princples:
+ - Simplicity: there are three commands (change focus, split, close). There are
+ no modes, no dozens of commands, no crazy feature list.
+ - Compatibility: mtm emulates a classic ANSI text terminal. That means it
+ should work out of the box on essentially all terminfo/termcap-based systems
+ (even pretty old ones), without needing to install a new termcap entry.
+ - Size mtm is small. The entire project is around 1000 lines of code.
+ - Stability: mtm is "finished" as it is now. You don't need to worry about it
+ changing on you unexpectedly. The only changes that can happen at this point
+ are:
+ - Bug fixes.
+ - Translation improvements.
+ - Accessibility improvements.
+ - Fixes to keep it working on modern OSes.
+
+WWW: https://github.com/deadpixi/mtm