aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-21 02:47:57 +0800
committermiwi <miwi@FreeBSD.org>2007-03-21 02:47:57 +0800
commit234471aeb2912c7a333b0403d16d5afb468384f3 (patch)
treeecaf8432dec0725889e62619a9a6da3aced12478
parent784132c3ad52432d729c42ed946a2cd105e88094 (diff)
downloadfreebsd-ports-gnome-234471aeb2912c7a333b0403d16d5afb468384f3.tar.gz
freebsd-ports-gnome-234471aeb2912c7a333b0403d16d5afb468384f3.tar.zst
freebsd-ports-gnome-234471aeb2912c7a333b0403d16d5afb468384f3.zip
- Pass maintainership to submitter
- Use TCL/TK 8.4 PR: 110314 Submitted by: Martin Tournoij <carpetsmoker@xs4all.nl>
-rw-r--r--editors/vigor/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/editors/vigor/Makefile b/editors/vigor/Makefile
index c9b3a5223684..663b15fb6055 100644
--- a/editors/vigor/Makefile
+++ b/editors/vigor/Makefile
@@ -7,30 +7,30 @@
PORTNAME= vigor
PORTVERSION= 0.016
-CATEGORIES= editors tk82 tcl82
+PORTREVISION= 1
+CATEGORIES= editors tk84 tcl84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= carpetsmoker@xs4all.nl
COMMENT= A vi clone inspired by the userfriendly comic strip
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82 \
- tcl82.1:${PORTSDIR}/lang/tcl82
-
+USE_TCL= yes
+USE_TCL_BUILD= yes
+USE_TK= yes
+USE_TK_BUILD= yes
+USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--program-transform-name="s,0,1,"
CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-USE_XLIB= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/build
-CFLAGS+= -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/tk8.2
+WRKSRC= ${WRKDIR}/${DISTNAME}/build
+CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/tk${TK_VER}
-# Uglyness. So is "-ltcl -ltk -ltcl", so I don't feel bad.
post-patch:
- ${REINPLACE_CMD} \
- -e 's,-ltcl,-ltcl82 -L${LOCALBASE}/lib,g' \
- -e 's,-ltk,-ltk82,g' \
- -e 's,^grantpt,XXXgrantpt,g' \
- ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|tcl80|tcl${TCL_VER:S/.//} -L${LOCALBASE}/lib|; \
+ s|tk80|tk${TK_VER:S/.//}|; \
+ s|^grantpt|XXXgrantpt|;' \
+ ${WRKSRC}/configure
.include <bsd.port.mk>