aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-01-07 14:16:27 +0800
committerrm <rm@FreeBSD.org>2013-01-07 14:16:27 +0800
commit23828257e4fe98bbfbe873dba84c1d166e35c763 (patch)
treeabc58f942292a37a4e689cfc40001763a20b1e58
parent14ce76fd7eca3744291789264e917f78ffa8eace (diff)
downloadfreebsd-ports-gnome-23828257e4fe98bbfbe873dba84c1d166e35c763.tar.gz
freebsd-ports-gnome-23828257e4fe98bbfbe873dba84c1d166e35c763.tar.zst
freebsd-ports-gnome-23828257e4fe98bbfbe873dba84c1d166e35c763.zip
JavaScript minifier.
WWW: http://pypi.python.org/pypi/jsmin PR: 174564 Submitted by: Po-Chien Lin <linpc@cs.nctu.edu.tw>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jsmin/Makefile32
-rw-r--r--devel/py-jsmin/distinfo2
-rw-r--r--devel/py-jsmin/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f92f0ba942b6..fbe17ec8411a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3450,6 +3450,7 @@
SUBDIR += py-iterpipes
SUBDIR += py-itools
SUBDIR += py-jcc
+ SUBDIR += py-jsmin
SUBDIR += py-json-py
SUBDIR += py-jsonlib
SUBDIR += py-jsonlib2
diff --git a/devel/py-jsmin/Makefile b/devel/py-jsmin/Makefile
new file mode 100644
index 000000000000..bf308164adce
--- /dev/null
+++ b/devel/py-jsmin/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chien Lin <linpc@cs.nctu.edu.tw>
+# $FreeBSD$
+
+PORTNAME= jsmin
+PORTVERSION= 2.0.2
+CATEGORIES= devel www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= linpc@cs.nctu.edu.tw
+COMMENT= JavaScript minifier written in Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PORTDOCS= PKG-INFO
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+.include <bsd.port.options.mk>
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+regression-test:
+ @(cd ${WRKSRC}/${PORTNAME} && ${PYTHON_CMD} test.py)
+
+.include <bsd.port.mk>
diff --git a/devel/py-jsmin/distinfo b/devel/py-jsmin/distinfo
new file mode 100644
index 000000000000..3c58c3b1cd23
--- /dev/null
+++ b/devel/py-jsmin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jsmin-2.0.2.tar.gz) = 544349a6665b85719185d1253047ea5e0aa21251e67e2e2f32d0f5772cd2d431
+SIZE (jsmin-2.0.2.tar.gz) = 5402
diff --git a/devel/py-jsmin/pkg-descr b/devel/py-jsmin/pkg-descr
new file mode 100644
index 000000000000..3bdcb817624d
--- /dev/null
+++ b/devel/py-jsmin/pkg-descr
@@ -0,0 +1,3 @@
+JavaScript minifier.
+
+WWW: http://pypi.python.org/pypi/jsmin