aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-03-30 01:43:34 +0800
committermi <mi@FreeBSD.org>2002-03-30 01:43:34 +0800
commit24a84a9fd8c28336fe529581563bd4f7b5ec69be (patch)
treebed800a83040f0449d9c5b9979a2eb56e6461c26
parenta3156490fabaeafdf0d7380514db76ac3ddb50f5 (diff)
downloadfreebsd-ports-gnome-24a84a9fd8c28336fe529581563bd4f7b5ec69be.tar.gz
freebsd-ports-gnome-24a84a9fd8c28336fe529581563bd4f7b5ec69be.tar.zst
freebsd-ports-gnome-24a84a9fd8c28336fe529581563bd4f7b5ec69be.zip
Make work with the new bsd.port.mk. The benefit of the magick, that
used to work to figure out the name of the installed library automaticly is, probably, not worth the disadvantages USE_SUBMAKE would bring. Just hardcode the SHLIB_NAME and figure the SHLIB_LINK from it. While I'm here, add tcl-memchan to the BUILD_DEPEND, so the automatic self-testing is done every time this package is built Submitted by: bento
-rw-r--r--devel/tcl-trf/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index 8f211864a79b..4420a1239584 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -15,7 +15,8 @@ DISTNAME= trf${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
-BUILD_DEPENDS= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}
+BUILD_DEPENDS= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//} \
+ ${LOCALBASE}/lib/tcl${TCL_VER}/Memchan/pkgIndex.tcl:${PORTSDIR}/devel/tcl-memchan
USE_BZIP2= yes
@@ -57,9 +58,7 @@ post-install:
.include <bsd.port.mk>
-.if exists(${WRKSRC}/${MAKEFILE})
-SHLIB_NAME!= ${MAKE} -f ${WRKSRC}/${MAKEFILE} -V Trf_LIB_FILE
+SHLIB_NAME= libTrf2.so.1
SHLIB_LINK= ${SHLIB_NAME:C/\.so\..*/.so/}
-.endif
PLIST_SUB+= SHLIB_NAME=${SHLIB_NAME} SHLIB_LINK=${SHLIB_LINK}