aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-01-12 01:17:20 +0800
committererwin <erwin@FreeBSD.org>2006-01-12 01:17:20 +0800
commit25355ca901103627b45a50bc61a776d32f81b6a9 (patch)
tree2d29d6f5dc6e0832814ec056d06281811647b092
parent2fbf301bdc2efd0acb50542c600ec8656c90d7da (diff)
downloadfreebsd-ports-gnome-25355ca901103627b45a50bc61a776d32f81b6a9.tar.gz
freebsd-ports-gnome-25355ca901103627b45a50bc61a776d32f81b6a9.tar.zst
freebsd-ports-gnome-25355ca901103627b45a50bc61a776d32f81b6a9.zip
This module provides a Catalyst::Log implementation that uses
Log::Log4perl as the underlying log mechanism. WWW: http://search.cpan.org/dist/Catalyst-Log-Log4perl/ PR: ports/91669 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Log-Log4perl/Makefile30
-rw-r--r--www/p5-Catalyst-Log-Log4perl/distinfo3
-rw-r--r--www/p5-Catalyst-Log-Log4perl/pkg-descr4
-rw-r--r--www/p5-Catalyst-Log-Log4perl/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d2e0191d2c22..fdef80394d15 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -497,6 +497,7 @@
SUBDIR += p5-Catalyst
SUBDIR += p5-Catalyst-Engine-Apache
SUBDIR += p5-Catalyst-Helper-Controller-Scaffold
+ SUBDIR += p5-Catalyst-Log-Log4perl
SUBDIR += p5-Catalyst-Model-CDBI
SUBDIR += p5-Catalyst-Model-CDBI-Sweet
SUBDIR += p5-Catalyst-Model-DBIC
diff --git a/www/p5-Catalyst-Log-Log4perl/Makefile b/www/p5-Catalyst-Log-Log4perl/Makefile
new file mode 100644
index 000000000000..24916ed21f8d
--- /dev/null
+++ b/www/p5-Catalyst-Log-Log4perl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: www/p5-Catalyst-Log-Log4perl
+# Date created: Jan 11 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Log-Log4perl
+PORTVERSION= 0.1
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Log::Log4perl logging for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=5.30:${PORTSDIR}/www/p5-Catalyst \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Log::Log4perl.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Log-Log4perl/distinfo b/www/p5-Catalyst-Log-Log4perl/distinfo
new file mode 100644
index 000000000000..3414e581ecac
--- /dev/null
+++ b/www/p5-Catalyst-Log-Log4perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Log-Log4perl-0.1.tar.gz) = 4ad243479b66f3960dce2b6297842952
+SHA256 (Catalyst-Log-Log4perl-0.1.tar.gz) = 6766bbb347d2df1ed9805a3a5302ffe30ba867d9f1236cb3c934cceebc15ef09
+SIZE (Catalyst-Log-Log4perl-0.1.tar.gz) = 2870
diff --git a/www/p5-Catalyst-Log-Log4perl/pkg-descr b/www/p5-Catalyst-Log-Log4perl/pkg-descr
new file mode 100644
index 000000000000..c8e81851eb98
--- /dev/null
+++ b/www/p5-Catalyst-Log-Log4perl/pkg-descr
@@ -0,0 +1,4 @@
+This module provides a Catalyst::Log implementation that uses
+Log::Log4perl as the underlying log mechanism.
+
+WWW: http://search.cpan.org/dist/Catalyst-Log-Log4perl/
diff --git a/www/p5-Catalyst-Log-Log4perl/pkg-plist b/www/p5-Catalyst-Log-Log4perl/pkg-plist
new file mode 100644
index 000000000000..39662d24f44b
--- /dev/null
+++ b/www/p5-Catalyst-Log-Log4perl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Catalyst/Log/Log4perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Log/Log4perl/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Log/Log4perl 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Log 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Log 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true