aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2017-02-02 01:42:40 +0800
committerlev <lev@FreeBSD.org>2017-02-02 01:42:40 +0800
commit28176524096acb891303e801926202af7b090c8d (patch)
tree8585c0259de58bd3d140bf349de0710b4579035b
parentaaf7c439682c2dc081b0c52216eb70bb781bd9c8 (diff)
downloadfreebsd-ports-gnome-28176524096acb891303e801926202af7b090c8d.tar.gz
freebsd-ports-gnome-28176524096acb891303e801926202af7b090c8d.tar.zst
freebsd-ports-gnome-28176524096acb891303e801926202af7b090c8d.zip
Fix shebang fix for new sed(1) behavior
PR: 215230 Submitted by: Xin Li <delphij@FreeBSD.org>
-rw-r--r--devel/subversion/Makefile.common5
-rw-r--r--devel/subversion18/Makefile.common5
2 files changed, 6 insertions, 4 deletions
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 924f7e4bb710..e1e2f68a986f 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -105,8 +105,9 @@ post-patch:
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
# shebangfix
- @${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
- | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ @${FIND} ${WRKSRC}/tools/ -type f -exec ${GREP} -l -e '#!/bin/b' -e '#!/bin/env' \
+ -e '#!/usr/bin/p' {} + | ${XARGS} ${REINPLACE_CMD} -e \
+ '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
-e '1s|#\!/bin/env|#\!/usr/bin/env|' \
-e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
# remove all .bak files to clean the stage
diff --git a/devel/subversion18/Makefile.common b/devel/subversion18/Makefile.common
index 2d5ab1eb1652..30c699c345bd 100644
--- a/devel/subversion18/Makefile.common
+++ b/devel/subversion18/Makefile.common
@@ -108,8 +108,9 @@ post-patch:
@${ECHO_CMD} "#define ORGANIZATION_NAME \"${ORGANIZATION}\"" > ${WRKSRC}/subversion/freebsd-organization.h
.endif
# shebangfix
- @${GREP} -Rl -e '#!/bin/b' -e '#!/bin/env' -e '#!/usr/bin/p' ${WRKSRC}/tools/ \
- | ${XARGS} ${REINPLACE_CMD} -e '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
+ @${FIND} ${WRKSRC}/tools/ -type f -exec ${GREP} -l -e '#!/bin/b' -e '#!/bin/env' \
+ -e '#!/usr/bin/p' {} + | ${XARGS} ${REINPLACE_CMD} -e \
+ '1s|#\!/bin/b|#\!/usr/local/bin/b|' \
-e '1s|#\!/bin/env|#\!/usr/bin/env|' \
-e '1s|#\!/usr/bin/p|#\!/usr/local/bin/p|'
# remove all .bak files to clean the stage