aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-20 00:07:53 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-20 00:07:53 +0800
commit2a436b5bb7568b04e46c047da8b86dcd45672006 (patch)
tree132e6c8a2f42be0f79f3fcc7ab6b9c005d785dba
parentf288d6b11836b4c01052945b07b757129ef02211 (diff)
downloadfreebsd-ports-gnome-2a436b5bb7568b04e46c047da8b86dcd45672006.tar.gz
freebsd-ports-gnome-2a436b5bb7568b04e46c047da8b86dcd45672006.tar.zst
freebsd-ports-gnome-2a436b5bb7568b04e46c047da8b86dcd45672006.zip
Use USE_GNOMENG.
Suggested by: Roberto Gerola <roberto.gerola@speedtech.it>
-rw-r--r--editors/scite/Makefile3
-rw-r--r--editors/scite/files/patch-SciTEGTK.cxx14
2 files changed, 16 insertions, 1 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index 1b5222d0baf6..c4f30173a0f6 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -22,7 +22,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehier gtk12
MAKEFILE= makefile
MAKE_ENV= MKDIR="${MKDIR}"
diff --git a/editors/scite/files/patch-SciTEGTK.cxx b/editors/scite/files/patch-SciTEGTK.cxx
new file mode 100644
index 000000000000..7f7d45b0dc13
--- /dev/null
+++ b/editors/scite/files/patch-SciTEGTK.cxx
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- SciTEGTK.cxx 2002/08/19 16:01:39 1.1
++++ SciTEGTK.cxx 2002/08/19 16:02:02
+@@ -1882,7 +1882,7 @@
+ return 0;
+ }
+
+-void SciTEGTK::AddToPopUp(const char *label, int cmd=0, bool enabled=true) {
++void SciTEGTK::AddToPopUp(const char *label, int cmd, bool enabled) {
+ SString localised = LocaliseString(label);
+ localised.insert(0, "/");
+ GtkItemFactoryEntry itemEntry = {