aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-09-04 20:07:28 +0800
committersat <sat@FreeBSD.org>2006-09-04 20:07:28 +0800
commit2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9 (patch)
tree3e31f9762ca14101a29c727a49db98bd45357de8
parentd37ad52865f1d948e101bef07468c53ceaf0e96d (diff)
downloadfreebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.tar.gz
freebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.tar.zst
freebsd-ports-gnome-2a9c70514e76a04540ff59dc2f65ac87e0c4b9f9.zip
Add port graphics/gscan2pdf:
A GUI to ease the process of producing PDFs from scanned documents WWW: http://sourceforge.net/projects/gscan2pdf Author: Jeffrey Ratcliffe <jeffreyratcliffe@yahoo.co.uk>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gscan2pdf/Makefile31
-rw-r--r--graphics/gscan2pdf/distinfo3
-rw-r--r--graphics/gscan2pdf/pkg-descr4
4 files changed, 39 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 50c837cb8dd2..3dab2b10034b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -216,6 +216,7 @@
SUBDIR += graphviz
SUBDIR += gridpix
SUBDIR += grx
+ SUBDIR += gscan2pdf
SUBDIR += gsculpt
SUBDIR += gstreamer-plugins-aalib
SUBDIR += gstreamer-plugins-aalib80
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
new file mode 100644
index 000000000000..c644322c2945
--- /dev/null
+++ b/graphics/gscan2pdf/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gscan2pdf
+# Date created: 4 September 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gscan2pdf
+PORTVERSION= 0.6.1
+CATEGORIES= graphics
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Produce PDF from scanned documents
+
+RUN_DEPENDS= tiff2pdf:${PORTSDIR}/graphics/tiff \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -Ee 's!tiff2pdf (.*) \$$options!tiff2pdf \$$options \1!' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/graphics/gscan2pdf/distinfo b/graphics/gscan2pdf/distinfo
new file mode 100644
index 000000000000..939ec7ff757d
--- /dev/null
+++ b/graphics/gscan2pdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (gscan2pdf_0.6.1.tar.gz) = bd524016eae918ffc76ecd672e60b262
+SHA256 (gscan2pdf_0.6.1.tar.gz) = 7f3814eb5e712911d989aef9c7234335f144d21db000389a7c2aa94019a9c4c6
+SIZE (gscan2pdf_0.6.1.tar.gz) = 21963
diff --git a/graphics/gscan2pdf/pkg-descr b/graphics/gscan2pdf/pkg-descr
new file mode 100644
index 000000000000..ed0e965c326a
--- /dev/null
+++ b/graphics/gscan2pdf/pkg-descr
@@ -0,0 +1,4 @@
+A GUI to ease the process of producing PDFs from scanned documents
+
+WWW: http://sourceforge.net/projects/gscan2pdf
+Author: Jeffrey Ratcliffe <jeffreyratcliffe@yahoo.co.uk>