aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-10-01 09:04:22 +0800
committerswills <swills@FreeBSD.org>2011-10-01 09:04:22 +0800
commit2a9de19f8013502622fec2f76d6d33364f5a39c8 (patch)
tree5e2d0f4964a45c23ae5021b4d336420ad38490bf
parentd274857c32c59d75da930188611710a0dfbc4aa9 (diff)
downloadfreebsd-ports-gnome-2a9de19f8013502622fec2f76d6d33364f5a39c8.tar.gz
freebsd-ports-gnome-2a9de19f8013502622fec2f76d6d33364f5a39c8.tar.zst
freebsd-ports-gnome-2a9de19f8013502622fec2f76d6d33364f5a39c8.zip
- Add build depends to quiet warning
- Add test depends for testing
-rw-r--r--devel/p5-App-GitGot/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/p5-App-GitGot/Makefile b/devel/p5-App-GitGot/Makefile
index ee4267b9803d..5915eb49f0d6 100644
--- a/devel/p5-App-GitGot/Makefile
+++ b/devel/p5-App-GitGot/Makefile
@@ -17,7 +17,7 @@ COMMENT= Tool to make it easier to manage multiple git repositories
LICENSE= ART20 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Config-INI>=0:${PORTSDIR}/devel/p5-Config-INI \
+BUILD_DEPENDS= p5-Config-INI>=0:${PORTSDIR}/devel/p5-Config-INI \
p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
p5-Git-Wrapper>=0.014:${PORTSDIR}/devel/p5-Git-Wrapper \
@@ -30,6 +30,13 @@ RUN_DEPENDS= p5-Config-INI>=0:${PORTSDIR}/devel/p5-Config-INI \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Class>=0:${PORTSDIR}/devel/p5-Test-Class \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-File>=0:${PORTSDIR}/devel/p5-Test-File \
+ p5-Sort-Versions>=0:${PORTSDIR}/devel/p5-Sort-Versions
+
PERL_CONFIGURE= yes
MAN1= got.1