aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-11-01 23:04:35 +0800
committerwill <will@FreeBSD.org>2000-11-01 23:04:35 +0800
commit2b85136d0764dd10396f482e0989be119d07ceae (patch)
tree5790261599e828f1daae154b669cbac18f493adb
parent000130e5f38d63a62bc3411120d60d04f46c6d98 (diff)
downloadfreebsd-ports-gnome-2b85136d0764dd10396f482e0989be119d07ceae.tar.gz
freebsd-ports-gnome-2b85136d0764dd10396f482e0989be119d07ceae.tar.zst
freebsd-ports-gnome-2b85136d0764dd10396f482e0989be119d07ceae.zip
Fix [pre,post]-install to use pkg-install script properly. Use forward
ticks instead of double quotes for the replace message to get rid of the backquote hack. PR: 21349 (related to it anyway) Submitted by: Yarema <yds@dppl.com>
-rw-r--r--mail/postfix-current/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index 7387594dd86e..83cf4b8b404b 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -99,7 +99,7 @@ post-patch:
${ECHO} "all: default" >> Makefile)
pre-install:
- ${SH} ${PKGINSTALL} Postfix PRE-INSTALL
+ @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} Postfix PRE-INSTALL
do-install:
@${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 0755 \
@@ -163,10 +163,13 @@ do-install:
@${MKDIR} -m 755 /var/spool/postfix
@${CHOWN} root:wheel /var/spool/postfix
- @${ECHO_MSG} "--------------------------------------------------"
- @${ECHO_MSG} "- To replace your existing sendmail with postfix -"
- @${ECHO_MSG} "- type \"make replace\" -"
- @${ECHO_MSG} "--------------------------------------------------"
+ @${ECHO_MSG} '--------------------------------------------------'
+ @${ECHO_MSG} '- To replace your existing sendmail with postfix -'
+ @${ECHO_MSG} '- type "make replace" -'
+ @${ECHO_MSG} '--------------------------------------------------'
+
+post-install:
+ @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.pre.mk>