aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2016-09-06 21:19:52 +0800
committerlev <lev@FreeBSD.org>2016-09-06 21:19:52 +0800
commit2c9b4f6d6123397972c7b326f687a4870252b536 (patch)
tree0bd44dace4b8632ed30e763b6f8178b1f52e432d
parent1060279472bb8378025f19aac0daa75c089d71de (diff)
downloadfreebsd-ports-gnome-2c9b4f6d6123397972c7b326f687a4870252b536.tar.gz
freebsd-ports-gnome-2c9b4f6d6123397972c7b326f687a4870252b536.tar.zst
freebsd-ports-gnome-2c9b4f6d6123397972c7b326f687a4870252b536.zip
Update to 1.3.9
Simplify Makefile PR: 212345, 206359 Submitted by: Olli Hauer <ohauer@FreeBSD.org>, John Hein <z7dr6ut7gs@snkmail.com>
-rw-r--r--www/serf/Makefile19
-rw-r--r--www/serf/distinfo5
-rw-r--r--www/serf/files/patch-SConstruct14
3 files changed, 18 insertions, 20 deletions
diff --git a/www/serf/Makefile b/www/serf/Makefile
index 398d3c866cbe..e014287f7694 100644
--- a/www/serf/Makefile
+++ b/www/serf/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= serf
-PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTVERSION= 1.3.9
+#PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= APACHE/serf
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS+= libapr-1.so:devel/apr1
-USES= scons tar:bzip2 cpe
-USE_OPENSSL= yes
+USES= scons ssl tar:bzip2 cpe
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
@@ -46,12 +45,6 @@ SCONS_ARGS+= GSSAPI="/usr"
SCONS_ARGS+= GSSAPI="${LOCALBASE}"
.endif
-do-build:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_CMD} ${SCONS_ARGS})
-
-do-install:
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_CMD} ${SCONS_ARGS} ${INSTALL_TARGET})
-
post-patch:
@${REINPLACE_CMD} -E \
-e '/^Requires.private/s/(libssl|libcrypto)//g' \
@@ -66,4 +59,8 @@ post-install-DOCS-on:
regression-test check: build
@(cd ${WRKSRC} && ${MAKE_CMD} check)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+MAKE_ARGS= ${SCONS_ARGS}
+
+.include <bsd.port.post.mk>
diff --git a/www/serf/distinfo b/www/serf/distinfo
index 440d8c626c66..b4697f171a76 100644
--- a/www/serf/distinfo
+++ b/www/serf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (serf-1.3.8.tar.bz2) = e0500be065dbbce490449837bb2ab624e46d64fc0b090474d9acaa87c82b2590
-SIZE (serf-1.3.8.tar.bz2) = 143337
+TIMESTAMP = 1472645004
+SHA256 (serf-1.3.9.tar.bz2) = 549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf7a87cc
+SIZE (serf-1.3.9.tar.bz2) = 145132
diff --git a/www/serf/files/patch-SConstruct b/www/serf/files/patch-SConstruct
index 1379ccf94381..25cb7b7e51d1 100644
--- a/www/serf/files/patch-SConstruct
+++ b/www/serf/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2014-02-05 00:11:10.000000000 +0400
-+++ SConstruct 2015-10-19 15:07:53.089322358 +0300
-@@ -69,6 +69,9 @@
+--- SConstruct.orig 2015-09-17 12:46:24 UTC
++++ SConstruct
+@@ -74,6 +74,9 @@ else:
opts = Variables(files=[SAVED_CONFIG])
opts.AddVariables(
@@ -10,7 +10,7 @@
PathVariable('PREFIX',
'Directory to install under',
default_prefix,
-@@ -203,6 +206,7 @@
+@@ -208,6 +211,7 @@ opts.Save(SAVED_CONFIG, env)
thisdir = os.getcwd()
libdir = '$LIBDIR'
incdir = '$PREFIX/include/serf-$MAJOR'
@@ -18,7 +18,7 @@
# This version string is used in the dynamic library name, and for Mac OS X also
# for the current_version and compatibility_version options in the .dylib
-@@ -345,8 +349,8 @@
+@@ -364,8 +368,8 @@ else:
### there is probably a better way to run/capture output.
### env.ParseConfig() may be handy for getting this stuff into the build
if CALLOUT_OKAY:
@@ -29,7 +29,7 @@
else:
apr_libs = ''
apu_libs = ''
-@@ -387,6 +391,8 @@
+@@ -406,6 +410,8 @@ pkgconfig = env.Textfile('serf-%d.pc' %
env.Default(lib_static, lib_shared, pkgconfig)
@@ -38,7 +38,7 @@
if CALLOUT_OKAY:
conf = Configure(env)
-@@ -418,7 +424,7 @@
+@@ -437,7 +443,7 @@ if sys.platform == 'darwin':
env.Alias('install-lib', [install_static, install_shared,
])
env.Alias('install-inc', env.Install(incdir, HEADER_FILES))