aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2017-02-02 05:49:18 +0800
committerolgeni <olgeni@FreeBSD.org>2017-02-02 05:49:18 +0800
commit2e2b26041f078a18da69f3dc89b8cdba4f098e8b (patch)
tree4eb828b159523ebcf981a4731e1b5c5d98bc2517
parentbc7595690fa5fe65a7e8a3089c0b230b022e61d6 (diff)
downloadfreebsd-ports-gnome-2e2b26041f078a18da69f3dc89b8cdba4f098e8b.tar.gz
freebsd-ports-gnome-2e2b26041f078a18da69f3dc89b8cdba4f098e8b.tar.zst
freebsd-ports-gnome-2e2b26041f078a18da69f3dc89b8cdba4f098e8b.zip
Update lang/erlang-wx to 19.2.2 and fix build with clang 4.0[1].
PR: 216615 [1] Submitted by: Jan Beich
-rw-r--r--lang/erlang-wx/Makefile4
-rw-r--r--lang/erlang-wx/distinfo4
-rw-r--r--lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp20
3 files changed, 25 insertions, 3 deletions
diff --git a/lang/erlang-wx/Makefile b/lang/erlang-wx/Makefile
index b99bf73e0826..bcc3f03cfb27 100644
--- a/lang/erlang-wx/Makefile
+++ b/lang/erlang-wx/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= erlang
-PORTVERSION= 19.2.1
+PORTVERSION= 19.2.2
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -14,7 +14,7 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= http://olgeni.olgeni.com/~olgeni/distfiles/ \
LOCAL/olgeni
-PATCHFILES= patch-otp-19.2.1
+PATCHFILES= patch-otp-19.2.1 patch-otp-19.2.2
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Erlang bindings for wxWindows
diff --git a/lang/erlang-wx/distinfo b/lang/erlang-wx/distinfo
index 82d38a3683cb..508620f0db7a 100644
--- a/lang/erlang-wx/distinfo
+++ b/lang/erlang-wx/distinfo
@@ -1,7 +1,9 @@
-TIMESTAMP = 1484655871
+TIMESTAMP = 1485949081
SHA256 (erlang/otp_src_19.2.tar.gz) = a016b3ef5dac1e532972617b2715ef187ecb616f7cd7ddcfe0f1d502f5d24870
SIZE (erlang/otp_src_19.2.tar.gz) = 68395949
SHA256 (erlang/otp_doc_html_19.2.tar.gz) = c373c8c1a9fe7433825088684932f3ded76f53d5b8a4d3d2a364263f1f783043
SIZE (erlang/otp_doc_html_19.2.tar.gz) = 34761971
SHA256 (erlang/patch-otp-19.2.1) = 5fe07da09c914e1145c3e15e2f459fdb7cceedec0213a289ad238dada9645d2c
SIZE (erlang/patch-otp-19.2.1) = 9287
+SHA256 (erlang/patch-otp-19.2.2) = a64cac32675fe57cb749461eba9458bbc4d7abddf58996c897e2528a41f2e33c
+SIZE (erlang/patch-otp-19.2.2) = 9412
diff --git a/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp b/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp
new file mode 100644
index 000000000000..5b1e66586f2f
--- /dev/null
+++ b/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp
@@ -0,0 +1,20 @@
+--- lib/wx/c_src/wxe_impl.cpp.orig 2017-01-30 23:13:25 UTC
++++ lib/wx/c_src/wxe_impl.cpp
+@@ -666,7 +666,7 @@ void * WxeApp::getPtr(char * bp, wxeMemE
+ throw wxe_badarg(index);
+ }
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL)))
++ if((index < memenv->next) && ((index == 0) || (temp != NULL)))
+ return temp;
+ else {
+ throw wxe_badarg(index);
+@@ -678,7 +678,7 @@ void WxeApp::registerPid(char * bp, ErlD
+ if(!memenv)
+ throw wxe_badarg(index);
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL))) {
++ if((index < memenv->next) && ((index == 0) || (temp != NULL))) {
+ ptrMap::iterator it;
+ it = ptr2ref.find(temp);
+ if(it != ptr2ref.end()) {