aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormux <mux@FreeBSD.org>2006-08-28 03:16:22 +0800
committermux <mux@FreeBSD.org>2006-08-28 03:16:22 +0800
commit2e63bab9ac58c1a8257eadd72eea87d76e2e54a7 (patch)
treefdbe5209e8f3ebb25f8164891dc7f916bbafe4ac
parentc05ac13d5740c66e115eeb1a43999c5d499bb3e4 (diff)
downloadfreebsd-ports-gnome-2e63bab9ac58c1a8257eadd72eea87d76e2e54a7.tar.gz
freebsd-ports-gnome-2e63bab9ac58c1a8257eadd72eea87d76e2e54a7.tar.zst
freebsd-ports-gnome-2e63bab9ac58c1a8257eadd72eea87d76e2e54a7.zip
Add a patch from vendor that fixes a crash with TreeView widgets and
bump PORTREVISION. Approved by: obraun
-rw-r--r--x11-toolkits/hs-gtk2hs/Makefile2
-rw-r--r--x11-toolkits/hs-gtk2hs/files/patch-glib-System-Glib-GValue.chs11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-toolkits/hs-gtk2hs/Makefile b/x11-toolkits/hs-gtk2hs/Makefile
index 5feb67721bcb..4d59d80ec874 100644
--- a/x11-toolkits/hs-gtk2hs/Makefile
+++ b/x11-toolkits/hs-gtk2hs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtk2hs
PORTVERSION= 0.9.10
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= x11-toolkits haskell
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/x11-toolkits/hs-gtk2hs/files/patch-glib-System-Glib-GValue.chs b/x11-toolkits/hs-gtk2hs/files/patch-glib-System-Glib-GValue.chs
new file mode 100644
index 000000000000..b41da090718d
--- /dev/null
+++ b/x11-toolkits/hs-gtk2hs/files/patch-glib-System-Glib-GValue.chs
@@ -0,0 +1,11 @@
+--- glib/System/Glib/GValue.chs.orig 2005-04-18 22:04:08.000000000 -0400
++++ glib/System/Glib/GValue.chs 2006-03-05 14:53:20.000000000 -0400
+@@ -68,7 +68,7 @@ valueGetType (GValue gvPtr) = {# get GVa
+ --
+ allocaGValue :: (GValue -> IO b) -> IO b
+ allocaGValue body =
+- allocaBytes {# sizeof GValue #} $ \gvPtr -> do
++ allocaBytes ({# sizeof GType #}+ 2* {# sizeof guint64 #}) $ \gvPtr -> do
+ -- The g_type field of the value must be zero or g_value_init will fail.
+ {# set GValue->g_type #} gvPtr (0 :: GType)
+ result <- body (GValue gvPtr)