aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-17 15:28:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-17 15:28:07 +0800
commit32c6bef6ca680f678419ba75e833aff8fc9dc78f (patch)
tree2cb3c52ed5598988694e7fed6bcfad000f025c65
parentdafa787c5c568874033b7169f7a25ee704303140 (diff)
downloadfreebsd-ports-gnome-32c6bef6ca680f678419ba75e833aff8fc9dc78f.tar.gz
freebsd-ports-gnome-32c6bef6ca680f678419ba75e833aff8fc9dc78f.tar.zst
freebsd-ports-gnome-32c6bef6ca680f678419ba75e833aff8fc9dc78f.zip
- Add p5-AnyEvent-BDB 1.1
AnyEvent::BDB is an AnyEvent user, you need to make sure that you use and run a supported event loop. Loading this module will install the necessary magic to seamlessly integrate BDB into AnyEvent, i.e. you no longer need to concern yourself with calling BDB::poll_cb or any of that stuff (you still can, but this module will do it in case you don't). The AnyEvent watcher can be disabled by executing undef $AnyEvent::BDB::WATCHER. Please notify the author of when and why you think this was necessary. WWW: http://search.cpan.org/dist/AnyEvent-BDB/
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-AnyEvent-BDB/Makefile24
-rw-r--r--databases/p5-AnyEvent-BDB/distinfo2
-rw-r--r--databases/p5-AnyEvent-BDB/pkg-descr12
-rw-r--r--databases/p5-AnyEvent-BDB/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 95c39902e077..dbd7997c44f4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -263,6 +263,7 @@
SUBDIR += oracle8-client
SUBDIR += oracle_odbc_driver
SUBDIR += p5-Amazon-SimpleDB
+ SUBDIR += p5-AnyEvent-BDB
SUBDIR += p5-AnyEvent-DBD-Pg
SUBDIR += p5-AnyEvent-Redis
SUBDIR += p5-ApacheDBILogConfig
diff --git a/databases/p5-AnyEvent-BDB/Makefile b/databases/p5-AnyEvent-BDB/Makefile
new file mode 100644
index 000000000000..0680b989b43d
--- /dev/null
+++ b/databases/p5-AnyEvent-BDB/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-AnyEvent-BDB
+# Date created: 2011-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AnyEvent-BDB
+PORTVERSION= 1.1
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Truly asynchronous berkeley db access
+
+RUN_DEPENDS= p5-AnyEvent>=3.81:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-BDB>=1.5:${PORTSDIR}/databases/p5-BDB
+
+PERL_CONFIGURE= yes
+
+MAN3= AnyEvent::BDB.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-AnyEvent-BDB/distinfo b/databases/p5-AnyEvent-BDB/distinfo
new file mode 100644
index 000000000000..6c2668f63b2e
--- /dev/null
+++ b/databases/p5-AnyEvent-BDB/distinfo
@@ -0,0 +1,2 @@
+SHA256 (AnyEvent-BDB-1.1.tar.gz) = 93e36010940464626e5f31b9faedd65e12ed8d1abf16ce052febf23f495aefc8
+SIZE (AnyEvent-BDB-1.1.tar.gz) = 2063
diff --git a/databases/p5-AnyEvent-BDB/pkg-descr b/databases/p5-AnyEvent-BDB/pkg-descr
new file mode 100644
index 000000000000..50734f9f8beb
--- /dev/null
+++ b/databases/p5-AnyEvent-BDB/pkg-descr
@@ -0,0 +1,12 @@
+AnyEvent::BDB is an AnyEvent user, you need to make sure that you use and run a
+supported event loop.
+
+Loading this module will install the necessary magic to seamlessly integrate BDB
+into AnyEvent, i.e. you no longer need to concern yourself with calling
+BDB::poll_cb or any of that stuff (you still can, but this module will do it in
+case you don't).
+
+The AnyEvent watcher can be disabled by executing undef $AnyEvent::BDB::WATCHER.
+Please notify the author of when and why you think this was necessary.
+
+WWW: http://search.cpan.org/dist/AnyEvent-BDB/
diff --git a/databases/p5-AnyEvent-BDB/pkg-plist b/databases/p5-AnyEvent-BDB/pkg-plist
new file mode 100644
index 000000000000..26f40e9b0654
--- /dev/null
+++ b/databases/p5-AnyEvent-BDB/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/AnyEvent/BDB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/BDB/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent/BDB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AnyEvent
+@dirrmtry %%SITE_PERL%%/AnyEvent