aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-09-06 05:32:14 +0800
committerantoine <antoine@FreeBSD.org>2013-09-06 05:32:14 +0800
commit3314cad3bb428f0b4e4d7cb699087233d4dae879 (patch)
tree28e15dd7054c672279e72d81b733f6bf110bbd35
parentd2d7db707ae090c6103f2a48abb34edbb0250bbd (diff)
downloadfreebsd-ports-gnome-3314cad3bb428f0b4e4d7cb699087233d4dae879.tar.gz
freebsd-ports-gnome-3314cad3bb428f0b4e4d7cb699087233d4dae879.tar.zst
freebsd-ports-gnome-3314cad3bb428f0b4e4d7cb699087233d4dae879.zip
Add an explicit dependency on pkgconf
Approved by: portmgr (bapt)
-rw-r--r--accessibility/accerciser/Makefile2
-rw-r--r--devel/anjuta/Makefile3
-rw-r--r--misc/bigboard/Makefile8
-rw-r--r--ports-mgmt/bpm/Makefile4
-rw-r--r--ports-mgmt/bpm/pkg-plist2
-rw-r--r--x11-wm/compiz-plugins-extra/Makefile3
6 files changed, 7 insertions, 15 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index d087d37d4a16..5e219752e538 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -15,7 +15,7 @@ COMMENT= Interactive Python accessibility explorer for GNOME
USE_BZIP2= yes
USE_GNOME= pygnomedesktop atspi intlhack
USE_PYTHON= yes
-USES= gettext gmake display:configure
+USES= display:configure gettext gmake pkgconfig
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index c71e1ca9f1d5..adf1167dd142 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -31,10 +31,9 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
CONFLICTS= anjuta-3.[0-9]*
USE_BZIP2= yes
-USES= gmake gettext pathfix shebangfix shared-mime-info
+USES= gmake gettext pathfix perl5 pkgconfig shebangfix shared-mime-info
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
-USE_PERL5= yes
USE_PYTHON= yes
USE_GNOME= gnomeprefix vte gtksourceview2 libgda4
USE_CSTD= gnu89
diff --git a/misc/bigboard/Makefile b/misc/bigboard/Makefile
index 07ce56b6cfec..b35187555dd6 100644
--- a/misc/bigboard/Makefile
+++ b/misc/bigboard/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bigboard
-# Date created: 2008-05-28
-# Whom: Ashish Shukla <wahjava@gmail.com>
-#
+# Created by: Ashish Shukla <wahjava@gmail.com>
# $FreeBSD$
-#
PORTNAME= bigboard
PORTVERSION= 0.5.38
@@ -29,7 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/desktop-data-engine:${PORTSDIR}/net/desktop-da
${LOCALBASE}/libdata/pkgconfig/gnome-python-2.0.pc:${PORTSDIR}/x11-toolkits/py-gnome2 \
${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_PYTHON= 2.5+
diff --git a/ports-mgmt/bpm/Makefile b/ports-mgmt/bpm/Makefile
index aea9b838a9a6..bfe771250634 100644
--- a/ports-mgmt/bpm/Makefile
+++ b/ports-mgmt/bpm/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
gnomesu:${PORTSDIR}/security/libgnomesu \
gdialog:${PORTSDIR}/x11/zenity
-USE_GNOME= gtk20 desktopfileutils
+USES= desktop-file-utils pkgconfig
+USE_GNOME= gtk20
MAKE_ENV+= OSTYPE="${OPSYS}"
@@ -32,6 +33,5 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKDIR}/bpm.desktop ${PREFIX}/share/applications/bpm.desktop
- @-update-desktop-database
.include <bsd.port.mk>
diff --git a/ports-mgmt/bpm/pkg-plist b/ports-mgmt/bpm/pkg-plist
index e1f9ea3fb0a0..4feb89f2e4ff 100644
--- a/ports-mgmt/bpm/pkg-plist
+++ b/ports-mgmt/bpm/pkg-plist
@@ -10,8 +10,6 @@ libexec/bpm/fetch-wrapper
%%DATADIR%%/pixmaps/lock_48.png
share/locale/en_CA/LC_MESSAGES/bpm.mo
share/applications/bpm.desktop
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrm libexec/bpm
@dirrm %%DATADIR%%/pixmaps
@dirrm %%DATADIR%%
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/x11-wm/compiz-plugins-extra/Makefile b/x11-wm/compiz-plugins-extra/Makefile
index f6a30d7b93f5..31b5a880cd50 100644
--- a/x11-wm/compiz-plugins-extra/Makefile
+++ b/x11-wm/compiz-plugins-extra/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USE_GL= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USES= pathfix gettext
+USES= gettext gmake pathfix pkgconfig
USE_GNOME= intltool
USE_XORG= glproto
USE_LDCONFIG= yes