aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-26 13:31:59 +0800
committerjhale <jhale@FreeBSD.org>2012-10-26 13:31:59 +0800
commit34fbc04a12095f7e641771db31eb2c6c56e18f6d (patch)
tree4f2a4962366efecfb96370e6ccdb8807695036a9
parent611687b198027b1b20ed405f9835a8822b76fd7c (diff)
downloadfreebsd-ports-gnome-34fbc04a12095f7e641771db31eb2c6c56e18f6d.tar.gz
freebsd-ports-gnome-34fbc04a12095f7e641771db31eb2c6c56e18f6d.tar.zst
freebsd-ports-gnome-34fbc04a12095f7e641771db31eb2c6c56e18f6d.zip
- Add fix to allow building with clang
- Trim Makefile header PR: ports/172609 Submitted by: Jan Beich <jbeich@tormail.org> Approved by: makc, avilla (mentors, implicit) Feature safe: yes
-rw-r--r--audio/oss/Makefile8
-rw-r--r--audio/oss/files/patch-setup-srcconf.c9
2 files changed, 11 insertions, 6 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index 95802bfdc130..92f4d19da5f2 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: oss
-# Date created: 2007-06-14
-# Whom: Edward Tomasz Napierala <trasz@FreeBSD.org>
-#
+# Created by: Edward Tomasz Napierala <trasz@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= oss
DISTVERSION= 4.2-build2007
@@ -54,7 +50,7 @@ PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss
-CONFIGURE_ENV= HOSTCC="${CC}"
+CONFIGURE_ENV= CC="${CC}" HOSTCC="${CC}"
OPTIONS_DEFINE= VORBIS
OPTIONS_DEFAULT=VORBIS
diff --git a/audio/oss/files/patch-setup-srcconf.c b/audio/oss/files/patch-setup-srcconf.c
index cd377fddf595..c058fce01c82 100644
--- a/audio/oss/files/patch-setup-srcconf.c
+++ b/audio/oss/files/patch-setup-srcconf.c
@@ -9,3 +9,12 @@
}
if (strcmp (line, "project") == 0)
+@@ -913,7 +913,7 @@
+ if (config_phpmake)
+ fprintf (f, "<?php require getenv(\"PHPMAKE_LIBPATH\") . \"library.php\"; phpmake_makefile_top_rules(); ?>\n");
+
+- fprintf (f, "CC=%s\n", conf.ccomp);
++ fprintf (f, "CC=%s\n", targetcc);
+ // fprintf (f, "LD=ld\n");
+ fprintf (f, "HOSTCC=%s\n", hostcc);
+ fprintf (f, "CPLUSPLUS=%s\n", conf.cplusplus);