aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlawrance <lawrance@FreeBSD.org>2006-05-14 19:08:25 +0800
committerlawrance <lawrance@FreeBSD.org>2006-05-14 19:08:25 +0800
commit36b3af30ecee400e42e72107bdb0deab32c5e56d (patch)
treeb631668d8e10d21d17a078eae9f3237d44202b7e
parentfabe6563d6f875515d8f8a7147819b6b5ebd793c (diff)
downloadfreebsd-ports-gnome-36b3af30ecee400e42e72107bdb0deab32c5e56d.tar.gz
freebsd-ports-gnome-36b3af30ecee400e42e72107bdb0deab32c5e56d.tar.zst
freebsd-ports-gnome-36b3af30ecee400e42e72107bdb0deab32c5e56d.zip
Use SUB_FILES instead of post-patch commands.
PR: ports/97223 Submitted by: Ports Fury
-rw-r--r--print/gsfonts/Makefile10
-rw-r--r--print/gsfonts/files/pkg-message.in16
-rw-r--r--print/gsfonts/pkg-message12
3 files changed, 22 insertions, 16 deletions
diff --git a/print/gsfonts/Makefile b/print/gsfonts/Makefile
index 9c175d52c560..20bdfd041f2b 100644
--- a/print/gsfonts/Makefile
+++ b/print/gsfonts/Makefile
@@ -23,8 +23,8 @@ NO_BUILD= yes
PLIST_SUB= FONTSDIR="${FONTSDIR:S|${PREFIX}/||}"
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+SUB_LIST= FONTSDIR="${FONTSDIR}"
#
# Local variables
@@ -37,7 +37,6 @@ GS_FONTS_OTHER= ghostscript-fonts-other-6.0.tar.gz
.SILENT:
post-patch:
- ${SED} 's|%%FONTSDIR%%|${FONTSDIR}|g' ${MSG_FILE} > ${PKGMESSAGE}
${CP} ${WRKSRC}/fonts/fonts.scale ${WRKSRC}/fonts/fonts.scale.urw
${CP} ${FILESDIR}/fonts.scale ${WRKSRC}/fonts/fonts.scale
${CP} ${FILESDIR}/fonts.scale ${WRKSRC}/fonts/fonts.dir
@@ -47,7 +46,7 @@ post-patch:
# Install
#
-do-install: install-fonts install-docs
+do-install: install-fonts install-docs display-message
install-fonts:
${MKDIR} ${FONTSDIR}
@@ -71,4 +70,7 @@ install-docs:
${INSTALL_DATA} ${WRKSRC}/fonts/TODO ${DOCSDIR}
.endif
+display-message:
+ ${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/print/gsfonts/files/pkg-message.in b/print/gsfonts/files/pkg-message.in
new file mode 100644
index 000000000000..36b5a77fe8d0
--- /dev/null
+++ b/print/gsfonts/files/pkg-message.in
@@ -0,0 +1,16 @@
+===========================================================================
+
+IMPORTANT - READ CAREFULLY: Please read the COPYRIGHT included with these
+fonts before using. The copyright can be found at %%FONTSDIR%%/COPYING.
+To use these fonts, follow the instructions below.
+
+Make sure that the freetype module is loaded. If it is not, add the
+following line to the "Modules" section of XF86Config:
+
+ Load "freetype"
+
+Add the following line to the "Files" section of XF86Config:
+
+ FontPath "%%FONTSDIR%%/"
+
+===========================================================================
diff --git a/print/gsfonts/pkg-message b/print/gsfonts/pkg-message
deleted file mode 100644
index a60519906c0c..000000000000
--- a/print/gsfonts/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-IMPORTANT - READ CAREFULLY: Please read the COPYRIGHT included with these fonts
-before using. The copyright can be found at %%FONTSDIR%%/COPYING. To
-use these fonts, follow the instructions below.
-
-Make sure that the freetype module is loaded. If it is not, add the following
-line to the "Modules" section of XF86Config:
-
- Load "freetype"
-
-Add the following line to the "Files" section of XF86Config:
-
- FontPath "%%FONTSDIR%%/"