aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-11-20 04:14:00 +0800
committermarino <marino@FreeBSD.org>2014-11-20 04:14:00 +0800
commit3cb431b29d9379aa30da52e23ffc5ead2b411684 (patch)
tree185da51bf97abc86a160bcc9c968167b8735cc54
parent0881f3ae69ad2ec669d5f816697c6d0552f353d7 (diff)
downloadfreebsd-ports-gnome-3cb431b29d9379aa30da52e23ffc5ead2b411684.tar.gz
freebsd-ports-gnome-3cb431b29d9379aa30da52e23ffc5ead2b411684.tar.zst
freebsd-ports-gnome-3cb431b29d9379aa30da52e23ffc5ead2b411684.zip
www/polipo: Fix use of cache directory
PR: 194813 Submitted by: WATANABE Kazuhiro Approved by: maintainer (Frank Behrens)
-rw-r--r--www/polipo/Makefile1
-rw-r--r--www/polipo/files/pkg-deinstall.in5
-rw-r--r--www/polipo/files/pkg-install.in6
-rw-r--r--www/polipo/pkg-plist2
4 files changed, 2 insertions, 12 deletions
diff --git a/www/polipo/Makefile b/www/polipo/Makefile
index 613db90619e6..84d13be51081 100644
--- a/www/polipo/Makefile
+++ b/www/polipo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= polipo
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.pps.univ-paris-diderot.fr/~jch/software/files/polipo/
diff --git a/www/polipo/files/pkg-deinstall.in b/www/polipo/files/pkg-deinstall.in
index 6dba407f4c88..9acb39352c2a 100644
--- a/www/polipo/files/pkg-deinstall.in
+++ b/www/polipo/files/pkg-deinstall.in
@@ -20,9 +20,6 @@ if pw usershow "${POLIPOUSER}" 2>/dev/null 1>&2; then
echo "---> To delete ${POLIPOUSER} user permanently, use 'pw userdel \"${POLIPOUSER}\"'"
fi
-if [ -d "$POLIPOCACHE" ]; then
- rm -r "$POLIPOCACHE" || exit 1
-fi
if [ -d "$PPIDDIR" ]; then
rm -r "$PPIDDIR" || exit 1
fi
@@ -31,6 +28,4 @@ if fgrep "${POLIPOLOG}" "/etc/newsyslog.conf" 2>/dev/null 1>&2; then
echo "---> You should remove from /etc/newsyslog.conf the \"${POLIPOLOG}\" entry manually."
fi
-rmdir $POLIPODATA/www/doc $POLIPODATA/www $POLIPODATA 2>/dev/null
-rmdir $PCONFIGDIR 2>/dev/null || echo "---> If you not plan to reinstall polipo, you can safely remove ${PCONFIGDIR}."
exit 0
diff --git a/www/polipo/files/pkg-install.in b/www/polipo/files/pkg-install.in
index ea423355c6ba..b1dae2ea9278 100644
--- a/www/polipo/files/pkg-install.in
+++ b/www/polipo/files/pkg-install.in
@@ -43,12 +43,6 @@ if [ "$2" = "PRE-INSTALL" ]; then
elif [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "%%DESTDIR%%$POLIPOCACHE" ]; then
- mkdir -p "%%DESTDIR%%$POLIPOCACHE" || exit 1
- chown "$POLIPOUSER:$POLIPOGROUP" "%%DESTDIR%%$POLIPOCACHE" || exit 1
- chmod ug=rwx,o= "%%DESTDIR%%$POLIPOCACHE" || exit 1
- fi
-
if [ ! -d "%%DESTDIR%%$PPIDDIR" ]; then
mkdir -p "%%DESTDIR%%$PPIDDIR" || exit 1
chgrp "$POLIPOGROUP" "%%DESTDIR%%$PPIDDIR" || exit 1
diff --git a/www/polipo/pkg-plist b/www/polipo/pkg-plist
index 700569f47193..5462987c86a9 100644
--- a/www/polipo/pkg-plist
+++ b/www/polipo/pkg-plist
@@ -4,4 +4,4 @@ bin/polipo
etc/periodic/daily/400.polipo
man/man1/polipo.1.gz
%%DATADIR%%/www/index.html
-@dir %%PCACHEDIR%%
+@dir(polipo,polipo,0770) %%PCACHEDIR%%