aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2004-10-29 04:07:05 +0800
committerlkoeller <lkoeller@FreeBSD.org>2004-10-29 04:07:05 +0800
commit3cb46afa97009eb3d990127617b75cc7da2d7765 (patch)
tree42eba717d24711105e804c847bfeb7bb8413086d
parent1561046edbeb2eba15c72207291f56bba7a1b805 (diff)
downloadfreebsd-ports-gnome-3cb46afa97009eb3d990127617b75cc7da2d7765.tar.gz
freebsd-ports-gnome-3cb46afa97009eb3d990127617b75cc7da2d7765.tar.zst
freebsd-ports-gnome-3cb46afa97009eb3d990127617b75cc7da2d7765.zip
o) Fix missing installation of sample and initial config files.
-rw-r--r--audio/rplay/Makefile8
-rw-r--r--audio/rplay/pkg-plist7
2 files changed, 13 insertions, 2 deletions
diff --git a/audio/rplay/Makefile b/audio/rplay/Makefile
index e150a5f923ea..6994628e0cf6 100644
--- a/audio/rplay/Makefile
+++ b/audio/rplay/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rplay
PORTVERSION= 3.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://rplay.doit.org/dist/
@@ -37,6 +37,12 @@ post-install:
@${ECHO_MSG} "===> Installing ${PREFIX}/etc/rc.d/rplayd.sh"
@${ECHO_MSG} "===> startup file as ${PREFIX}/etc/rc.d/rplayd.sh.sample"
@${INSTALL_SCRIPT} -m 751 ${FILESDIR}/rplayd.sh ${PREFIX}/etc/rc.d/rplayd.sh.sample
+ for na in rplay.conf rplay.helpers rplay.servers rplay.hosts; do \
+ ${CP} ${WRKSRC}/etc/$$na ${PREFIX}/etc/$$na.sample; \
+ if [ ! -f ${PREFIX}/etc/$$na ]; then \
+ ${CP} ${WRKSRC}/etc/$$na ${PREFIX}/etc/$$na; \
+ fi; \
+ done
.if !exists(${PREFIX}/etc/rplay.hosts)
@${ECHO_CMD} localhost > ${PREFIX}/etc/rplay.hosts
.endif
diff --git a/audio/rplay/pkg-plist b/audio/rplay/pkg-plist
index 60f23de0ee5d..9b9ab30faa27 100644
--- a/audio/rplay/pkg-plist
+++ b/audio/rplay/pkg-plist
@@ -1,7 +1,12 @@
etc/rc.d/rplayd.sh.sample
@unexec if cmp %D/etc/rplay.hosts.sample %D/etc/rplay.hosts 2>/dev/null; then rm -f %D/etc/rplay.hosts; fi
etc/rplay.hosts.sample
-@exec if test ! -f %D/etc/rplay.hosts; then cp -p %D/etc/rplay.hosts.sample %D/etc/rplay.hosts; fi
+@unexec if cmp %D/etc/rplay.conf.sample %D/etc/rplay.conf 2>/dev/null; then rm -f %D/etc/rplay.conf; fi
+etc/rplay.conf.sample
+@unexec if cmp %D/etc/rplay.helpers.sample %D/etc/rplay.helpers 2>/dev/null; then rm -f %D/etc/rplay.helpers; fi
+etc/rplay.helpers.sample
+@unexec if cmp %D/etc/rplay.servers.sample %D/etc/rplay.servers 2>/dev/null; then rm -f %D/etc/rplay.servers; fi
+etc/rplay.servers.sample
bin/rplay
bin/rptp
sbin/rplayd