aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-12-03 02:47:15 +0800
committerflo <flo@FreeBSD.org>2011-12-03 02:47:15 +0800
commit3e1f43538c161f6efd90a948995b046e91d04494 (patch)
tree564696ff73e60aa5a246df67ca0dd074ca6979d1
parentcdf0c3b9869c54e8a9edfaca4f8e7b8e709fa265 (diff)
downloadfreebsd-ports-gnome-3e1f43538c161f6efd90a948995b046e91d04494.tar.gz
freebsd-ports-gnome-3e1f43538c161f6efd90a948995b046e91d04494.tar.zst
freebsd-ports-gnome-3e1f43538c161f6efd90a948995b046e91d04494.zip
fix dependencies
Reported by: Thomas Sibley <trs@bestpractical.com> Reviewed by: Thomas Sibley <trs@bestpractical.com> Feature safe: yes
-rw-r--r--www/rt38/Makefile3
-rw-r--r--www/rt38/Makefile.cpan5
2 files changed, 5 insertions, 3 deletions
diff --git a/www/rt38/Makefile b/www/rt38/Makefile
index 1901006896a3..27b3978a2d30 100644
--- a/www/rt38/Makefile
+++ b/www/rt38/Makefile
@@ -13,6 +13,7 @@
PORTNAME= rt
PORTVERSION= 3.8.11
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.bestpractical.com/pub/rt/release/ \
ftp://ftp.eu.uu.net/pub/unix/ticketing/rt/release/
@@ -73,7 +74,7 @@ USE_APACHE= 13+
.if defined(WITH_FASTCGI)
BUILD_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi
RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
- ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FCGI
+ p5-FCGI>=0.74:${PORTSDIR}/www/p5-FCGI
.endif
.if defined(WITH_GRAPHVIZ)
diff --git a/www/rt38/Makefile.cpan b/www/rt38/Makefile.cpan
index bf451a6f7314..3c00a13144af 100644
--- a/www/rt38/Makefile.cpan
+++ b/www/rt38/Makefile.cpan
@@ -21,7 +21,8 @@ CORE_DEPS= p5-Encode>=2.21:${PORTSDIR}/converters/p5-Encode \
p5-Module-Versions-Report>=1.05:${PORTSDIR}/devel/p5-Module-Versions-Report \
p5-Devel-StackTrace>=1.19:${PORTSDIR}/devel/p5-Devel-StackTrace \
p5-Digest-MD5>=2.27:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-File-Temp>=0.18:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+ p5-File-Temp>=0.19:${PORTSDIR}/devel/p5-File-Temp \
p5-Tree-Simple>=1.04:${PORTSDIR}/devel/p5-Tree-Simple \
p5-HTML-Scrubber>=0.08:${PORTSDIR}/www/p5-HTML-Scrubber \
p5-DBIx-SearchBuilder>=1.54:${PORTSDIR}/databases/p5-DBIx-SearchBuilder \
@@ -98,4 +99,4 @@ SMTP_DEPS= p5-Net>=1.22:${PORTSDIR}/net/p5-Net
STANDALONE_DEPS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
p5-HTTP-Server-Simple>=0.34:${PORTSDIR}/www/p5-HTTP-Server-Simple \
- p5-HTTP-Server-Simple-Mason>=0.09:${PORTSDIR}/www/p5-HTTP-Server-Simple-Mason
+ p5-HTTP-Server-Simple-Mason>=0.14:${PORTSDIR}/www/p5-HTTP-Server-Simple-Mason