aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-07 23:52:40 +0800
committerbapt <bapt@FreeBSD.org>2014-03-07 23:52:40 +0800
commit3e95ed2d78436b302cc911ae8dcd3f0e2e0b3402 (patch)
treed85d1d826adfcc00724f4cb18ebe3b014d54fc70
parent852d5fb9c0e0348fd1eff348fb2e2e9bbe9bab9d (diff)
downloadfreebsd-ports-gnome-3e95ed2d78436b302cc911ae8dcd3f0e2e0b3402.tar.gz
freebsd-ports-gnome-3e95ed2d78436b302cc911ae8dcd3f0e2e0b3402.tar.zst
freebsd-ports-gnome-3e95ed2d78436b302cc911ae8dcd3f0e2e0b3402.zip
Convert b* to USES=zip
-rw-r--r--benchmarks/netio/Makefile3
-rw-r--r--benchmarks/pybench/Makefile4
-rw-r--r--benchmarks/scimark2/Makefile4
-rw-r--r--benchmarks/scimark2c/Makefile3
-rw-r--r--biology/biojava/Makefile2
-rw-r--r--biology/blat/Makefile3
-rw-r--r--biology/libsbml/Makefile3
-rw-r--r--biology/plink/Makefile3
-rw-r--r--biology/seqan/Makefile4
9 files changed, 12 insertions, 17 deletions
diff --git a/benchmarks/netio/Makefile b/benchmarks/netio/Makefile
index 0b91f4430c1f..1c168bfbffad 100644
--- a/benchmarks/netio/Makefile
+++ b/benchmarks/netio/Makefile
@@ -12,8 +12,7 @@ MAINTAINER= arved@FreeBSD.org
COMMENT= Network benchmark
WRKSRC= ${WRKDIR}
-USE_ZIP= yes
-USES= gmake
+USES= gmake zip
PLIST_FILES= bin/netio
CFLAGS+= -DUNIX ${PTHREAD_CFLAGS}
diff --git a/benchmarks/pybench/Makefile b/benchmarks/pybench/Makefile
index 9a74e7526c53..5fb2c8f1dcc4 100644
--- a/benchmarks/pybench/Makefile
+++ b/benchmarks/pybench/Makefile
@@ -5,13 +5,13 @@ PORTNAME= pybench
PORTVERSION= 2.0
CATEGORIES= benchmarks python
MASTER_SITES= http://downloads.egenix.com/python/
-EXTRACT_SUFX= .zip
MAINTAINER= sylvio@FreeBSD.org
-COMMENT= An extensible benchmark suite for Python
+COMMENT= Extensible benchmark suite for Python
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= zip
USE_PYTHON= yes
PORTDOCS= README
diff --git a/benchmarks/scimark2/Makefile b/benchmarks/scimark2/Makefile
index 7d17d0fbfdd6..00be7d1785ce 100644
--- a/benchmarks/scimark2/Makefile
+++ b/benchmarks/scimark2/Makefile
@@ -10,11 +10,11 @@ PKGNAMESUFFIX= -java
DISTNAME= ${PORTNAME}src
MAINTAINER= thierry@FreeBSD.org
-COMMENT= A Java benchmark for scientific and numerical computing
+COMMENT= Java benchmark for scientific and numerical computing
WRKSRC= ${WRKDIR}
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
NEED_JAVAC= yes
diff --git a/benchmarks/scimark2c/Makefile b/benchmarks/scimark2c/Makefile
index 97ab4facb511..3d8b5f9ddcca 100644
--- a/benchmarks/scimark2c/Makefile
+++ b/benchmarks/scimark2c/Makefile
@@ -6,11 +6,12 @@ DISTVERSION= 2_1
CATEGORIES= benchmarks
MASTER_SITES= http://math.nist.gov/scimark2/
DISTNAME= ${PORTNAME:S/2/${DISTVERSION}/}
-EXTRACT_SUFX= .zip
MAINTAINER= thierry@pompo.net
COMMENT= ANSI C version of the SciMark2 benchmark
+USES= zip
+
PLIST_FILES= bin/scimark2
WRKSRC= ${WRKDIR}
diff --git a/biology/biojava/Makefile b/biology/biojava/Makefile
index e1069a32ffa7..3de945e000cb 100644
--- a/biology/biojava/Makefile
+++ b/biology/biojava/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= .jar
MAINTAINER= wenheping@gmail.com
COMMENT= Open-source Java tools for processing biological data
-USE_ZIP= yes
+USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/biology/blat/Makefile b/biology/blat/Makefile
index c9c6ce6bc03b..a279e5ded906 100644
--- a/biology/blat/Makefile
+++ b/biology/blat/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= biology
MASTER_SITES= http://hgwdev.cse.ucsc.edu/~kent/src/ \
http://users.soe.ucsc.edu/~kent/src/
DISTNAME= ${PORTNAME}Src${PORTVERSION}
-EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast tool for local sequence similarity searches
@@ -18,7 +17,7 @@ OPTIONS_DEFINE= DOCS
WRKSRC= ${WRKDIR}/${PORTNAME}Src
-USES= gmake
+USES= gmake zip
USE_OPENSSL= yes
MAKEFILE= makefile
MAKE_ENV= MACHTYPE="${ARCH}" HOME="${WRKSRC}/${BINDIR}" STRIP="${TRUE}"
diff --git a/biology/libsbml/Makefile b/biology/libsbml/Makefile
index 9df43949a9bf..8440662751b9 100644
--- a/biology/libsbml/Makefile
+++ b/biology/libsbml/Makefile
@@ -15,8 +15,7 @@ LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
OPTIONS_DEFINE= PYTHON RUBY
-USE_GMAKE= yes
-USE_ZIP= yes
+USES= gmake zip
USE_GCC= any
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/biology/plink/Makefile b/biology/plink/Makefile
index a9711e69d1b5..c74534c61971 100644
--- a/biology/plink/Makefile
+++ b/biology/plink/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 2
CATEGORIES= biology science
MASTER_SITES= http://pngu.mgh.harvard.edu/~purcell/plink/dist/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
-EXTRACT_SUFX= .zip
MAINTAINER= jwbacon@tds.net
COMMENT= Whole genome association analysis toolset
@@ -17,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack
# We need Fortran LDFLAGS to link with Lapack.
-USES= fortran gmake
+USES= fortran gmake zip
PLIST_FILES= bin/plink
diff --git a/biology/seqan/Makefile b/biology/seqan/Makefile
index d6111ab720bf..1f1472494816 100644
--- a/biology/seqan/Makefile
+++ b/biology/seqan/Makefile
@@ -16,9 +16,7 @@ LICENSE_COMB= multi
LICENSE_FILE_BSD=${WRKSRC}/seqan/LICENSE
LICENSE_FILE_GPLv3=${WRKSRC}/apps/LICENSE
-USE_ZIP= yes
-
-USES= cmake:outsource
+USES= cmake:outsource zip
CMAKE_SOURCE_PATH=${WRKSRC}/cmake
USE_PYTHON_BUILD=yes
MAKE_JOB_SAFE= yes