aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-11-20 17:41:05 +0800
committerobraun <obraun@FreeBSD.org>2002-11-20 17:41:05 +0800
commit3eb8c901e591003665776dcfbf07ccbd2f105619 (patch)
tree91c48c8841c7d42576c1da05c22cf7a67dd36212
parent4b2d41d3db7a75b237b5c00d9e3faa788adfbbe4 (diff)
downloadfreebsd-ports-gnome-3eb8c901e591003665776dcfbf07ccbd2f105619.tar.gz
freebsd-ports-gnome-3eb8c901e591003665776dcfbf07ccbd2f105619.tar.zst
freebsd-ports-gnome-3eb8c901e591003665776dcfbf07ccbd2f105619.zip
Add pager 0.4a, a pager for sawfish without GNOME.
PR: 45517 Submitted by: Michael Ebert <ebert@informatik.unibw-muenchen.de>
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/pager/Makefile42
-rw-r--r--x11-wm/pager/distinfo1
-rw-r--r--x11-wm/pager/files/patch-pager.jl14
-rw-r--r--x11-wm/pager/pkg-comment1
-rw-r--r--x11-wm/pager/pkg-descr3
-rw-r--r--x11-wm/pager/pkg-message8
-rw-r--r--x11-wm/pager/pkg-plist4
8 files changed, 74 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 9784f468fb3f..aef8cc39dbc4 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -61,6 +61,7 @@
SUBDIR += olvwm
SUBDIR += openbox
SUBDIR += oroborus
+ SUBDIR += pager
SUBDIR += pekwm
SUBDIR += phluid
SUBDIR += piewm
diff --git a/x11-wm/pager/Makefile b/x11-wm/pager/Makefile
new file mode 100644
index 000000000000..8e7c09a8a8a8
--- /dev/null
+++ b/x11-wm/pager/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: pager
+# Date created: November 20 2002
+# Whom: Michael Ebert <ebert@informatik.unibw-muenchen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pager
+PORTVERSION= 0.4a
+CATEGORIES= x11-wm
+MASTER_SITES= http://dapfy.bei.t-online.de/sawfish/pager/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ebert@informatik.unibw-muenchen.de
+
+BUILD_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
+RUN_DEPENDS= ${X11BASE}/bin/sawfish:${PORTSDIR}/x11-wm/sawfish
+
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_GNOMENG= yes
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+
+SAWFISH_VERSION= `${X11BASE}/bin/sawfish --version 2>&1 | \
+ ${SED} 's/^.*version[ ]*\([0-9.]*\).*/\1/'`
+
+PLIST_SUB+= SAWFISH_VERSION="${SAWFISH_VERSION}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/gtk-config/gtk12-config/g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+# doesn't work correct with the compiled .jl file at the moment
+# ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jlc \
+# ${PREFIX}/share/sawfish/${SAWFISH_VERSION}/lisp/sawfish/wm/ext
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.jl \
+ ${PREFIX}/share/sawfish/${SAWFISH_VERSION}/lisp/sawfish/wm/ext
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-wm/pager/distinfo b/x11-wm/pager/distinfo
new file mode 100644
index 000000000000..43fd5f7c58ff
--- /dev/null
+++ b/x11-wm/pager/distinfo
@@ -0,0 +1 @@
+MD5 (pager-0.4a.tgz) = c67f36063e98ab81940c52b66a2c4212
diff --git a/x11-wm/pager/files/patch-pager.jl b/x11-wm/pager/files/patch-pager.jl
new file mode 100644
index 000000000000..62a57f06c112
--- /dev/null
+++ b/x11-wm/pager/files/patch-pager.jl
@@ -0,0 +1,14 @@
+--- pager.jl.orig Tue Nov 19 21:06:10 2002
++++ pager.jl Tue Nov 19 21:08:30 2002
+@@ -277,7 +277,10 @@
+ ;; Tells the C program to change the colors
+ (define (send-colors)
+ (send ?c
+- (mapcar color-rgb
++ (mapcar (lambda (color)
++ (let ((clist (color-rgb color)))
++ (setcdr (nthcdr 2 clist) nil)
++ clist))
+ (list pager-color-background
+ pager-color-viewport
+ pager-color-window
diff --git a/x11-wm/pager/pkg-comment b/x11-wm/pager/pkg-comment
new file mode 100644
index 000000000000..f7710034f485
--- /dev/null
+++ b/x11-wm/pager/pkg-comment
@@ -0,0 +1 @@
+A pager for sawfish without GNOME
diff --git a/x11-wm/pager/pkg-descr b/x11-wm/pager/pkg-descr
new file mode 100644
index 000000000000..5e0bc6bb9ce3
--- /dev/null
+++ b/x11-wm/pager/pkg-descr
@@ -0,0 +1,3 @@
+A pager for sawfish without GNOME
+
+WWW: http://dapfy.bei.t-online.de/sawfish/pager/
diff --git a/x11-wm/pager/pkg-message b/x11-wm/pager/pkg-message
new file mode 100644
index 000000000000..3f5364f386e2
--- /dev/null
+++ b/x11-wm/pager/pkg-message
@@ -0,0 +1,8 @@
+********************************************************************************
+To start the pager at the startup of sawfish add the following to
+your sawfish resource file (e.g. ~/.sawfishrc):
+
+ (require 'sawfish.wm.ext.pager)
+ (setq pager-executable "pager")
+ (add-hook 'after-initialization-hook pager t)
+********************************************************************************
diff --git a/x11-wm/pager/pkg-plist b/x11-wm/pager/pkg-plist
new file mode 100644
index 000000000000..42fb50fc932d
--- /dev/null
+++ b/x11-wm/pager/pkg-plist
@@ -0,0 +1,4 @@
+bin/pager
+share/sawfish/%%SAWFISH_VERSION%%/lisp/sawfish/wm/ext/pager.jl
+@comment share/sawfish/%%SAWFISH_VERSION%%/lisp/sawfish/wm/ext/pager.jlc
+@comment doesn't work correct with the compiled .jl file at the moment