aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-01-08 15:06:24 +0800
committerbapt <bapt@FreeBSD.org>2013-01-08 15:06:24 +0800
commit424941746fab63c1edfc32ba5e7c221f2cfa52e3 (patch)
treea7b4bed52842c2ad668f11ae7f5f5d4d02c1df8b
parent2d7d02066042eb68dc50872da09cf7eb6bfb0b41 (diff)
downloadfreebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.tar.gz
freebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.tar.zst
freebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.zip
Convert last python@ ports to new options framework
for both make options work as expected (previous version were missing include <bsd.port.options.mk>) for databases/py-pyPgSQL reverse the logic for the option test so that it actually works as expected Approved by: python (crees)
-rw-r--r--databases/py-pyPgSQL/Makefile18
-rw-r--r--x11-toolkits/py-gui/Makefile16
2 files changed, 16 insertions, 18 deletions
diff --git a/databases/py-pyPgSQL/Makefile b/databases/py-pyPgSQL/Makefile
index 3c52ebd6178a..98673a4bd3d5 100644
--- a/databases/py-pyPgSQL/Makefile
+++ b/databases/py-pyPgSQL/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-pypgsql
-# Date created: 01 Nov 2001
-# Whom: Gerhard Haering <gerhard.haering@gmx.de>
-#
+# Created by: Gerhard Haering <gerhard.haering@gmx.de>
# $FreeBSD$
-#
PORTNAME= pyPgSQL
PORTVERSION= 2.5.1
@@ -26,12 +22,16 @@ EXAMPLES= examples/*.py
DATETIME_DEP= ${PYTHON_SITELIBDIR}/mx/DateTime/__init__.py
-OPTIONS= BYTEA_CONN "Apply Bytea connection patch" On
+OPTIONS_DEFINE= BYTEA_CONN EXAMPLES DOCS
+OPTIONS_DEFAULT= BYTEA_CONN
+BYTEA_CONN_DESC= Apply Bytea connection patch
# bypass infrastructure bug
OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-.if !defined(WITH_BYTEA_CONN)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MBYTEA_CONN}
PATCH_SITES= http://sourceforge.net/tracker/download.php?group_id=16528&atid=316528&file_id=273956&aid=1939119/
PATCHFILES= pyPgSQL-patch_byteaconn
.endif
@@ -40,13 +40,13 @@ DOCSDIR= ${PREFIX}/share/doc/py-pyPgSQL
EXAMPLESDIR= ${PREFIX}/share/examples/py-pyPgSQL
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
.for f in ${EXAMPLES}
@${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
diff --git a/x11-toolkits/py-gui/Makefile b/x11-toolkits/py-gui/Makefile
index 52f9fc3e4994..73fa9518bd67 100644
--- a/x11-toolkits/py-gui/Makefile
+++ b/x11-toolkits/py-gui/Makefile
@@ -1,7 +1,4 @@
-# Ports collection makefile for: py-gui
-# Date created: 21 June 2004
-# Whom: Hye-Shik Chang
-#
+# Created by: Hye-Shik Chang
# $FreeBSD$
PORTNAME= gui
@@ -32,11 +29,12 @@ LATEST_LINK= py-${PORTNAME}
WRKSRC= ${WRKDIR}/PyGUI-${PORTVERSION}
-OPTIONS= GL "Enable GL support" off
+OPTIONS_DEFINE= OPENGL DOCS
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GL)
+.if ${PORT_OPTIONS:MOPENGL}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:${PORTSDIR}/x11-toolkits/py-gtkglext
.endif
@@ -49,7 +47,7 @@ post-patch:
${REINPLACE_CMD} -e 's/"GUI.Cocoa",//g' ${WRKSRC}/setup.py
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/${DOCSDIR}
${TAR} -C ${WRKSRC}/Doc -cf - . | ${TAR} -C ${PREFIX}/${DOCSDIR} -xf -
${MKDIR} ${PREFIX}/${EXAMPLESDIR}
@@ -59,4 +57,4 @@ post-install:
${TAR} -C ${PREFIX}/${EXAMPLESDIR} -xf -
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>