aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-01 13:28:13 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-01 13:28:13 +0800
commit426ab1fba122519ac35fa0df5c80094a88c2e2c7 (patch)
tree33940ac280d5d9c9bfbe0327dac11d41436f0b6f
parent78b6ba06e79e55eeaba471a56a61dade1e49b73c (diff)
downloadfreebsd-ports-gnome-426ab1fba122519ac35fa0df5c80094a88c2e2c7.tar.gz
freebsd-ports-gnome-426ab1fba122519ac35fa0df5c80094a88c2e2c7.tar.zst
freebsd-ports-gnome-426ab1fba122519ac35fa0df5c80094a88c2e2c7.zip
sysutils/qpxtool: unbreak with clang 4.0
src/mainwindow.cpp:429:9: error: ordered comparison between pointer and zero ('QAction *' and 'int') if (act<0) return; ~~~^~ Reported by: antoine (via exp-run)
-rw-r--r--sysutils/qpxtool/Makefile2
-rw-r--r--sysutils/qpxtool/files/patch-gui_src_mainwindow.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/sysutils/qpxtool/Makefile b/sysutils/qpxtool/Makefile
index 3a4ef6b3ed9a..d614cc5ca866 100644
--- a/sysutils/qpxtool/Makefile
+++ b/sysutils/qpxtool/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qpxtool
PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION:C/\.[^.]*$/.x/}/${DISTVERSION}
diff --git a/sysutils/qpxtool/files/patch-gui_src_mainwindow.cpp b/sysutils/qpxtool/files/patch-gui_src_mainwindow.cpp
new file mode 100644
index 000000000000..68f2588ca114
--- /dev/null
+++ b/sysutils/qpxtool/files/patch-gui_src_mainwindow.cpp
@@ -0,0 +1,11 @@
+--- gui/src/mainwindow.cpp.orig 2012-12-03 07:13:07 UTC
++++ gui/src/mainwindow.cpp
+@@ -426,7 +426,7 @@ void QPxToolMW::selectTab()
+ int idx;
+ QAction *act = (QAction*) sender();
+ idx = act_sblist.indexOf(act);
+- if (act<0) return;
++ if (act == NULL) return;
+ mwidget->selectTab(idx);
+ }
+