aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-20 06:12:09 +0800
committerale <ale@FreeBSD.org>2004-07-20 06:12:09 +0800
commit45041a050b284e69f2ee1e329a1b95a7e7b09554 (patch)
treef114e5164a2cad7d9da400eba7f828bdb190c5bd
parente4d6599538e78b8047cb76d1af64b97c0799dfae (diff)
downloadfreebsd-ports-gnome-45041a050b284e69f2ee1e329a1b95a7e7b09554.tar.gz
freebsd-ports-gnome-45041a050b284e69f2ee1e329a1b95a7e7b09554.tar.zst
freebsd-ports-gnome-45041a050b284e69f2ee1e329a1b95a7e7b09554.zip
Comment extension_dir in sample php.ini's, since many copy the sample
configuration file blindly and then complain about wrong directory. PHP has the correct path compiled in statically.
-rw-r--r--lang/php4/Makefile1
-rw-r--r--lang/php5/Makefile1
-rw-r--r--lang/php53/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index ec0728682ea9..f66f3cce3276 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -165,6 +165,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 9798ba3f6972..a9b6c5d4c999 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -170,6 +170,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 9798ba3f6972..a9b6c5d4c999 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -170,6 +170,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure: