aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-11-09 18:24:23 +0800
committergarga <garga@FreeBSD.org>2009-11-09 18:24:23 +0800
commit476c2d336689fdbcd7f51c1532bb35c69934a390 (patch)
tree31470448e77fda3404eb7480860c8f5d0d95db45
parent8c211fda21f628d1825a44782efa4c3335395ae5 (diff)
downloadfreebsd-ports-gnome-476c2d336689fdbcd7f51c1532bb35c69934a390.tar.gz
freebsd-ports-gnome-476c2d336689fdbcd7f51c1532bb35c69934a390.tar.zst
freebsd-ports-gnome-476c2d336689fdbcd7f51c1532bb35c69934a390.zip
Update to 1.4.24
PR: ports/140316 Approved by: maintainer by email
-rw-r--r--www/lighttpd/Makefile5
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src_mod_accesslog.c13
3 files changed, 18 insertions, 6 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 6a1ee62f3410..d5366346fac3 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.23
+PORTVERSION= 1.4.24
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
@@ -17,8 +17,7 @@ COMMENT= A secure, fast, compliant, and very flexible Web Server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_BZIP2= yes
-USE_AUTOTOOLS= aclocal:110 autoconf:262 autoheader:262 automake:110 libtool:22
-ACLOCAL_ARGS= --force
+USE_AUTOTOOLS= libtool:22
GNU_CONFIGURE= yes
USE_GNOME= lthack pkgconfig
USE_RC_SUBR= lighttpd.sh
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index 18756cc40c00..c6bcab1f650b 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.23.tar.bz2) = 0ab6bb7b17bf0f515ce7dce68e5e215a
-SHA256 (lighttpd-1.4.23.tar.bz2) = 72896e6677b12aee2371c12e6d3f8299cfbdb2f89ad4b519a96b3ba80852a5fa
-SIZE (lighttpd-1.4.23.tar.bz2) = 641621
+MD5 (lighttpd-1.4.24.tar.bz2) = e2324a24e4a5bce74663c21c58ddd200
+SHA256 (lighttpd-1.4.24.tar.bz2) = 6e643dc4627d742510afee67654291a5190a316f5737dfb463b158a70f24750e
+SIZE (lighttpd-1.4.24.tar.bz2) = 622842
diff --git a/www/lighttpd/files/patch-src_mod_accesslog.c b/www/lighttpd/files/patch-src_mod_accesslog.c
new file mode 100644
index 000000000000..e873fcfb9022
--- /dev/null
+++ b/www/lighttpd/files/patch-src_mod_accesslog.c
@@ -0,0 +1,13 @@
+--- src/mod_accesslog.c.orig 2009-11-05 12:40:58.000000000 -0200
++++ src/mod_accesslog.c 2009-11-05 12:41:17.000000000 -0200
+@@ -162,7 +162,9 @@
+ if (str->used == 0) return;
+ buffer_prepare_append(dest, str->used - 1);
+
+- for (unsigned int i = 0; i < str->used - 1; i++) {
++ unsigned int i;
++
++ for (i = 0; i < str->used - 1; i++) {
+ if (str->ptr[i] >= ' ' && str->ptr[i] <= '~') {
+ /* printable chars */
+ buffer_append_string_len(dest, &str->ptr[i], 1);