aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-19 21:41:51 +0800
committermat <mat@FreeBSD.org>2015-08-19 21:41:51 +0800
commit47900e9d4bacba66e2ff045420d9d83a295a542a (patch)
tree81a2ca31789f4172ca1be25f640fe0b45335d47a
parentb6fbcc59ce12b5456ed66f1b6348f4dda197f1dd (diff)
downloadfreebsd-ports-gnome-47900e9d4bacba66e2ff045420d9d83a295a542a.tar.gz
freebsd-ports-gnome-47900e9d4bacba66e2ff045420d9d83a295a542a.tar.zst
freebsd-ports-gnome-47900e9d4bacba66e2ff045420d9d83a295a542a.zip
Fix previous commit.
Pointy hat to: mat Sponsored by: Absolight
-rw-r--r--astro/boinc-setiathome-v7/Makefile6
-rw-r--r--audio/liblo/Makefile2
-rw-r--r--audio/ncmpc/Makefile1
-rw-r--r--audio/ncmpcpp/Makefile4
-rw-r--r--audio/shoutcast/Makefile2
-rw-r--r--audio/vagalume/Makefile1
-rw-r--r--biology/xmolwt/Makefile1
-rw-r--r--cad/dinotrace/Makefile1
-rw-r--r--comms/xastir/Makefile2
9 files changed, 10 insertions, 10 deletions
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index 868f53a9a700..2ff193c16c46 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -47,10 +47,8 @@ X11_CONFIGURE_ENABLE= graphics
X11_BUILD_DEPENDS_OFF= ${LOCALBASE}/include/boinc/std_fixes.h:${PORTSDIR}/net/boinc-client
-.if ${ARCH} == i386 || ${ARCH} == amd64
-# comment out if world is built with clang and port with gcc
-CFLAGS+= -mtune=native
-.endif
+CFLAGS_i386= -mtune=native
+CFLAGS_amd64= -mtune=native
.if !empty(MACHINE_CPU:Maltivec)
CONFIGURE_ARGS+= --enable-altivec
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index ecafb1ab3dc4..60286c9e2278 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -26,6 +26,8 @@ OPTIONS_SUB= yes
DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+.include <bsd.port.options.mk>
+
post-patch:
.if ${ARCH} == i386 || ${ARCH} == powerpc
@${REINPLACE_CMD} -e 's,deadbeef,, ; s,f00baa23,,' \
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index 045c11d52ab6..3fb0a277f067 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -60,6 +60,5 @@ do-install-LYRICS-on:
(cd ${WRKSRC}/lyrics && ${INSTALL_SCRIPT} \
10-hd.sh 20-lyricwiki.rb \
${STAGEDIR}${PREFIX}/lib/ncmpc/lyrics)
-.endif
.include <bsd.port.mk>
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index d9b2cc94695c..9b2c75dd9119 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -50,6 +50,8 @@ OUTPUTS_CONFIGURE_ENABLE= outputs
VISUALIZER_BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
VISUALIZER_CONFIGURE_ENABLE= visualizer
+.include <bsd.port.pre.mk>
+
.if ${NCURSESBASE} == /usr
# no need to use ncurses-config if we use ncurses from the base system
CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
@@ -62,4 +64,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/NEWS ${WRKSRC}/AUTHORS ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/bindings ${WRKSRC}/doc/config ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index a69caefd6984..2d0d1ba239c9 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -51,6 +51,8 @@ SUB_LIST= ${SHOUTCAST_SUB}
USERS= ${SHOUTCASTUSER}
GROUPS= ${SHOUTCASTGROUP}
+.include <bsd.port.options.mk>
+
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000010
.if ${ARCH} == "i386"
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index a31320342031..7a3fe10f7707 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -41,7 +41,6 @@ NLS_CONFIGURE_ENABLE= nls
GCONF_USE= GNOME=gconf2
GCONF_CONFIGURE_ENABLE= gconf
-.endif
post-patch:
@${REINPLACE_CMD} -e 's|serviceentrydir = @serviceentrydir@|serviceentrydir = ${PREFIX}/share/dbus-1/services|' \
diff --git a/biology/xmolwt/Makefile b/biology/xmolwt/Makefile
index d31361cea49e..4309337090b2 100644
--- a/biology/xmolwt/Makefile
+++ b/biology/xmolwt/Makefile
@@ -24,7 +24,6 @@ GTK2_USE= GNOME=gtk20
GTK2_MAKE_ENV= GTKCONFIG="pkg-config gtk+-2.0"
GTK2_USE_OFF= GNOME=gtk12
GTK2_MAKE_ENV_OFF= GTKCONFIG="${GTK_CONFIG}"
-.endif
post-patch:
@${REINPLACE_CMD} -e \
diff --git a/cad/dinotrace/Makefile b/cad/dinotrace/Makefile
index 85b4a3ee5afe..9e249116a1eb 100644
--- a/cad/dinotrace/Makefile
+++ b/cad/dinotrace/Makefile
@@ -41,6 +41,5 @@ post-install-EMACS-on:
.for F in dinotrace.el sim-log.el
${INSTALL_DATA} ${WRKSRC}/lisp/${F} ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 6e85bd03e14a..2953420cb319 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -74,4 +74,4 @@ OPTCFLAGS_CFLAGS= -O2 -pipe
BROKEN_sparc64= Does not compile on sparc64
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>