aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-10-28 02:52:36 +0800
committerrm <rm@FreeBSD.org>2012-10-28 02:52:36 +0800
commit4aff46980546465785f2e75079182ba5cc5da01a (patch)
treebc6308b8587ced5fe104f1801957b81e01c5927f
parent2cc03981f0536e8f3a7d72eb464edd45fd5a2e9a (diff)
downloadfreebsd-ports-gnome-4aff46980546465785f2e75079182ba5cc5da01a.tar.gz
freebsd-ports-gnome-4aff46980546465785f2e75079182ba5cc5da01a.tar.zst
freebsd-ports-gnome-4aff46980546465785f2e75079182ba5cc5da01a.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - trim Makefile header - limit python version to 2.x only - move pkg-plist contents into Makefile:PLIST_FILES - tab -> space change in pkg-descr:WWW Approved by: glarkin (maintainer, implicit) Feature safe: yes
-rw-r--r--www/trac-estimator/Makefile19
-rw-r--r--www/trac-estimator/pkg-descr2
-rw-r--r--www/trac-estimator/pkg-plist1
3 files changed, 8 insertions, 14 deletions
diff --git a/www/trac-estimator/Makefile b/www/trac-estimator/Makefile
index 1c37508aa82d..0cd1bf370c86 100644
--- a/www/trac-estimator/Makefile
+++ b/www/trac-estimator/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trac-estimator
-# Date created: February 26 2010
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Create by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= estimator
PORTVERSION= 0.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= http://www.sourcehosting.net/freebsd/distfiles/ \
LOCAL/glarkin
@@ -17,15 +13,14 @@ DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Produce detailed range-based estimations for Trac tickets
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
WRKSRC= ${WRKDIR}/${PORTNAME}plugin/0.11
-NO_BUILD= yes
-USE_PYTHON= 2.3+
-USE_PYDISTUTILS=yes
-PLIST_SUB+= PORTVERSION=${PORTVERSION:S/.r/_r/} PYTHONVERSION=${_PYTHON_VERSION}
-PYDISTUTILS_NOEGGINFO= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_PKGNAME= estimatorplugin
+PYDISTUTILS_PKGVERSION= ${PORTVERSION:S/.r/_r/}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/trac-estimator/pkg-descr b/www/trac-estimator/pkg-descr
index 3277a6f22ea1..3b327fa13c61 100644
--- a/www/trac-estimator/pkg-descr
+++ b/www/trac-estimator/pkg-descr
@@ -2,4 +2,4 @@ This Trac plugin implements a page for creating time estimates. The
estimates will be attached to whatever tickets are specified in the
tickets box.
-WWW: http://trac-hacks.org/wiki/EstimatorPlugin
+WWW: http://trac-hacks.org/wiki/EstimatorPlugin
diff --git a/www/trac-estimator/pkg-plist b/www/trac-estimator/pkg-plist
deleted file mode 100644
index 96ce700c0845..000000000000
--- a/www/trac-estimator/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-%%PYTHON_SITELIBDIR%%/estimatorplugin-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg