aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-05-03 16:47:22 +0800
committernivit <nivit@FreeBSD.org>2012-05-03 16:47:22 +0800
commit4b259e6e02e304d86109da1ecf0105f331063138 (patch)
treef4bba2996fc5880143f7c76c5a37b91ca79639e3
parent6f7704c98d611eb5ee5614e1ff150402d8c9b74e (diff)
downloadfreebsd-ports-gnome-4b259e6e02e304d86109da1ecf0105f331063138.tar.gz
freebsd-ports-gnome-4b259e6e02e304d86109da1ecf0105f331063138.tar.zst
freebsd-ports-gnome-4b259e6e02e304d86109da1ecf0105f331063138.zip
*cssselect* parses `CSS3 Selectors`_ and translate them to `XPath 1.0`_
expressions. Such expressions can be used in lxml_ or another XPath engine to find the matching elements in an XML or HTML document. This module used to live inside of lxml as ``lxml.cssselect`` before it was extracted as a stand-alone project. WWW: http://packages.python.org/cssselect/
-rw-r--r--www/Makefile1
-rw-r--r--www/py-cssselect/Makefile22
-rw-r--r--www/py-cssselect/distinfo2
-rw-r--r--www/py-cssselect/pkg-descr8
-rw-r--r--www/py-cssselect/pkg-plist2
5 files changed, 35 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 68b26bdb9fe7..fa4a44906f20 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1439,6 +1439,7 @@
SUBDIR += py-cherrypy
SUBDIR += py-cherrypy-old
SUBDIR += py-clientform
+ SUBDIR += py-cssselect
SUBDIR += py-cssutils
SUBDIR += py-django
SUBDIR += py-django-annoying
diff --git a/www/py-cssselect/Makefile b/www/py-cssselect/Makefile
new file mode 100644
index 000000000000..7ecc3cd05a63
--- /dev/null
+++ b/www/py-cssselect/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: cssselect
+# Date created: 2012-05-02
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cssselect
+PORTVERSION= 0.6.1
+#PORTREVISION= 0
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Cssselect parses CSS3 Selectors and translates them to XPath 1.0
+
+# Python3 ready
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/www/py-cssselect/distinfo b/www/py-cssselect/distinfo
new file mode 100644
index 000000000000..6aba9789fa60
--- /dev/null
+++ b/www/py-cssselect/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cssselect-0.6.1.tar.gz) = b35683a6526e24240606b46caf6f7c154a3c0f4ac4137fd2b073ddcfcb25445f
+SIZE (cssselect-0.6.1.tar.gz) = 29679
diff --git a/www/py-cssselect/pkg-descr b/www/py-cssselect/pkg-descr
new file mode 100644
index 000000000000..00e81a4ed339
--- /dev/null
+++ b/www/py-cssselect/pkg-descr
@@ -0,0 +1,8 @@
+*cssselect* parses `CSS3 Selectors`_ and translate them to `XPath 1.0`_
+expressions. Such expressions can be used in lxml_ or another XPath engine
+to find the matching elements in an XML or HTML document.
+
+This module used to live inside of lxml as ``lxml.cssselect`` before it was
+extracted as a stand-alone project.
+
+WWW: http://packages.python.org/cssselect/
diff --git a/www/py-cssselect/pkg-plist b/www/py-cssselect/pkg-plist
new file mode 100644
index 000000000000..7767d3e76aa1
--- /dev/null
+++ b/www/py-cssselect/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%