aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2017-02-02 06:10:08 +0800
committerdumbbell <dumbbell@FreeBSD.org>2017-02-02 06:10:08 +0800
commit4de7fbfce90a2b527f739c66b269531450d409f0 (patch)
tree6802a5e0a313d380057416a94623e4dd0d8074c5
parent467123648e700c53f04a670f69d546a82ebf2ab7 (diff)
downloadfreebsd-ports-gnome-4de7fbfce90a2b527f739c66b269531450d409f0.tar.gz
freebsd-ports-gnome-4de7fbfce90a2b527f739c66b269531450d409f0.tar.zst
freebsd-ports-gnome-4de7fbfce90a2b527f739c66b269531450d409f0.zip
graphics/darktable: Update to 2.2.3
Version 2.2.3 was released shortly after 2.2.2 with the patch to src/develop/imageop_math.c applied. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D9400
-rw-r--r--graphics/darktable/Makefile2
-rw-r--r--graphics/darktable/distinfo6
-rw-r--r--graphics/darktable/files/patch-src_develop_imageop__math.c18
3 files changed, 4 insertions, 22 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 76f5cfd212e5..5f34f6b77b31 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= darktable
-PORTVERSION= 2.2.2
+PORTVERSION= 2.2.3
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION:C/\.rc/rc/}/
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
index 9777af38528e..631ac5e956c9 100644
--- a/graphics/darktable/distinfo
+++ b/graphics/darktable/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485537770
-SHA256 (darktable-2.2.2.tar.xz) = 766d7d734e7bd5a33f6a6932a43b15cc88435c64ad9a0b20410ba5b4706941c2
-SIZE (darktable-2.2.2.tar.xz) = 3079424
+TIMESTAMP = 1485877660
+SHA256 (darktable-2.2.3.tar.xz) = 1b33859585bf283577680c61e3c0ea4e48214371453b9c17a86664d2fbda48a0
+SIZE (darktable-2.2.3.tar.xz) = 3079524
diff --git a/graphics/darktable/files/patch-src_develop_imageop__math.c b/graphics/darktable/files/patch-src_develop_imageop__math.c
deleted file mode 100644
index aa5460109b00..000000000000
--- a/graphics/darktable/files/patch-src_develop_imageop__math.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/develop/imageop_math.c.orig 2017-01-27 11:03:43 UTC
-+++ src/develop/imageop_math.c
-@@ -195,13 +195,13 @@ void dt_iop_clip_and_zoom_mosaic_half_si
-
- const float fy = (y + roi_out->y) * px_footprint;
- const int miny = CLAMPS((int)floorf(fy - px_footprint), 0, roi_in->height-3);
-- const int maxy = MIN(roi_in->height-1, (int)ceilf(fy + px_footprint));
-+ const int maxy = MIN(roi_in->height-2, (int)ceilf(fy + px_footprint));
-
- float fx = roi_out->x * px_footprint;
- for(int x = 0; x < roi_out->width; x++, fx += px_footprint, outc++)
- {
- const int minx = CLAMPS((int)floorf(fx - px_footprint), 0, roi_in->width-3);
-- const int maxx = MIN(roi_in->width-1, (int)ceilf(fx + px_footprint));
-+ const int maxx = MIN(roi_in->width-2, (int)ceilf(fx + px_footprint));
-
- const int c = FC(y, x, filters);
- int num = 0;