aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-02-19 07:05:36 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-02-19 07:05:36 +0800
commit5244d085b69beaaa823290647df67f2619ae1cf9 (patch)
tree348bfeadc29881337c80a4bc46d71929a36bd0b1
parentfef5f857f719e96d84e0e13ea83971220ce34a6c (diff)
downloadfreebsd-ports-gnome-5244d085b69beaaa823290647df67f2619ae1cf9.tar.gz
freebsd-ports-gnome-5244d085b69beaaa823290647df67f2619ae1cf9.tar.zst
freebsd-ports-gnome-5244d085b69beaaa823290647df67f2619ae1cf9.zip
- Add optional support for graphics/osg-devel, which should fix some rendering bugs
PR: 131613 Submitted by: Ganael Laplanche <ganael dot laplanche at martymac dot com> (maintainer)
-rw-r--r--devel/simgear/Makefile7
-rw-r--r--games/flightgear/Makefile7
2 files changed, 12 insertions, 2 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index f1e710ffe67a..a4b5991f6fe0 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -19,9 +19,14 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
jpeg.9:${PORTSDIR}/graphics/jpeg \
alut.1:${PORTSDIR}/audio/freealut \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
GNU_CONFIGURE= yes
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index c2feaaaf213a..52ad92713ae8 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -22,7 +22,6 @@ MAINTAINER= ganael.laplanche@martymac.com
COMMENT= The FlightGear flight simulator
LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
- osg.48:${PORTSDIR}/graphics/osg \
boost_thread.4:${PORTSDIR}/devel/boost
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
@@ -30,6 +29,12 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/flightgear-data
+.if defined(WITH_OSG_DEVEL)
+LIB_DEPENDS+= osg.54:${PORTSDIR}/graphics/osg-devel
+.else
+LIB_DEPENDS+= osg.48:${PORTSDIR}/graphics/osg
+.endif
+
USE_XORG= ice sm x11 xext xi xt xmu
USE_GL= gl glu glut
USE_GMAKE= yes