aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-11-04 08:06:22 +0800
committeredwin <edwin@FreeBSD.org>2006-11-04 08:06:22 +0800
commit5274649202f77a3be426ce1ba710eff0646c081b (patch)
tree9407db910fa2755ffcdbe87eb7be3d194e79fdf0
parentbd79f91aa14b3d674b863435324c2f5fd96f3225 (diff)
downloadfreebsd-ports-gnome-5274649202f77a3be426ce1ba710eff0646c081b.tar.gz
freebsd-ports-gnome-5274649202f77a3be426ce1ba710eff0646c081b.tar.zst
freebsd-ports-gnome-5274649202f77a3be426ce1ba710eff0646c081b.zip
unbreak for when py-lucence is installed
-rw-r--r--net/penguintv-devel/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/penguintv-devel/Makefile b/net/penguintv-devel/Makefile
index 4acf7409b104..da61007b3a52 100644
--- a/net/penguintv-devel/Makefile
+++ b/net/penguintv-devel/Makefile
@@ -23,9 +23,8 @@ BUILD_DEPENDS+= Xvfb:${X_VFBSERVER_PORT} \
.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= Cannot be run without PyLucence
-
-OPTIONS= MOZILLA "Use Mozilla rendered (experimental)" OFF
+OPTIONS= MOZILLA "Use Mozilla rendered (experimental)" OFF \
+ PYLUCENCE "Use Lucence search engine" ON
USE_GNOME= pygnomeextras pygnome2
USE_PYTHON= yes
@@ -34,6 +33,12 @@ CONFLICTS= PenguinTV-[0-9]*
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_PYLUCENCE)
+BROKEN= Cannot be run without PyLucence
+.else
+RUN_DEPENDS+= ${LOCALBASE}/lib/python2.4/site-packages/PyLucene.py:${PORTSDIR}/devel/py-lucence
+.endif
+
.if defined(WITH_MOZILLA)
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex \
mozilla-config:${PORTSDIR}/www/mozilla