aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-11-16 08:30:00 +0800
committergerald <gerald@FreeBSD.org>2015-11-16 08:30:00 +0800
commit5460b9367d5d517687a23e616ab09c2ee406ba27 (patch)
tree363506e7dd9e291951b16954bff2860dae770025
parent38112291e5d3544883030fdea903f53336d0117e (diff)
downloadfreebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.tar.gz
freebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.tar.zst
freebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.zip
Add GCC_DESC to Mk/bsd.options.desc.mk. Use this in a number of ports
instead of their own respective settings.
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--lang/erlang-runtime15/Makefile1
-rw-r--r--lang/erlang-runtime16/Makefile1
-rw-r--r--lang/erlang-runtime17/Makefile1
-rw-r--r--lang/erlang-runtime18/Makefile1
-rw-r--r--lang/erlang/Makefile1
-rw-r--r--lang/ghc/Makefile1
-rw-r--r--lang/ghc/bsd.cabal.options.mk1
-rw-r--r--multimedia/x264/Makefile1
-rw-r--r--net/asterisk11/Makefile1
-rw-r--r--net/asterisk13/Makefile1
-rw-r--r--security/cryptopp/Makefile1
-rw-r--r--www/mod_spdy/Makefile1
13 files changed, 1 insertions, 12 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 73ed2d862251..4504f331e908 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -102,6 +102,7 @@ FRIBIDI_DESC?= Bidirectional text support via GNU FriBidi
FTP_DESC?= FTP protocol support
FTPS_DESC?= FTP with SSL/TLS support
FUSE_DESC?= FUSE (Filesystem in Userspace) support
+GCC_DESC?= Build with modern GCC (from ports)
GCONF_DESC?= GConf configuration backend support
GCRYPT_DESC?= Use GNU crypt library instead of OpenSSL
GD_DESC?= GD graphics library support
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 79f0368d3e35..4e39dc254d12 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -30,7 +30,6 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 33682d16c151..652226a957d9 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -30,7 +30,6 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 73de1c7deff1..b8e9f4379e5e 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -37,7 +37,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 0f6f20bc7793..96ccdb9faf1f 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -37,7 +37,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 7be4297c909f..b463618c88b0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -42,7 +42,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index b6166458f47c..0d81c9994cae 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -51,7 +51,6 @@ OPTIONS_DEFAULT= PROFILE DYNAMIC DOCS GCC
BOOT_DESC= Use installed GHC for bootstrapping
BOOTH_DESC= Use installed HsColour for bootstrapping
-GCC_DESC= Build with GCC (from ports)
PCLANG_DESC= Build with Clang from ports
BCLANG_DESC= Build with Clang from base
PROFILE_DESC= Add support for performance profiling
diff --git a/lang/ghc/bsd.cabal.options.mk b/lang/ghc/bsd.cabal.options.mk
index ae70ad7ec24e..471815fde632 100644
--- a/lang/ghc/bsd.cabal.options.mk
+++ b/lang/ghc/bsd.cabal.options.mk
@@ -25,7 +25,6 @@ HSCOLOUR_DESC?= Colorize generated documentation by HsColour
DYNAMIC_DESC?= Add support for dynamic linking
PROFILE_DESC?= Add support for profiling
LLVM_DESC?= Use the LLVM backend for code generation
-GCC_DESC= Build with GCC (from ports)
PCLANG_DESC= Build with Clang from ports
BCLANG_DESC= Build with Clang from base
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 894202ed778d..60ead2e5b309 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -50,7 +50,6 @@ HAS_CONFIGURE= yes
OPTIONS_DEFINE?= ASM DEBUG GCC GPAC LAVF PGO
OPTIONS_DEFAULT?= ASM GPAC
-GCC_DESC= Use current GCC
GPAC_DESC= MPEG-4 output support
LAVF_DESC= libav* format input/output support (requires FFmpeg)
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 31dee5e0e2b5..987743c0035a 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -96,7 +96,6 @@ BACKTRACE_DESC= Stack backtrace support via (lib)execinfo
BASE_DESC= Use base compiler (experimental)
DAHDI_DESC= DAHDI support
EXCHANGE_DESC= Exchange calendar support
-GCC_DESC= Use GCC from ports
MP3PLAYER_DESC= Install MP3 Player for Music-On-Hold (mpg123)
NEWG711_DESC= New G711 codec
OOH323_DESC= ooh323 support
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index a23d4675b4b6..205badda39bd 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -101,7 +101,6 @@ BACKTRACE_DESC?= Stack backtrace support via (lib)execinfo
BASE_DESC= Use base compiler (experimental)
DAHDI_DESC?= DAHDI support
EXCHANGE_DESC?= Exchange calendar support
-GCC_DESC= Use GCC from ports
MP3PLAYER_DESC= Install MP3 Player for Music-On-Hold (mpg123)
NEWG711_DESC?= New G711 Codec
OOH323_DESC?= ooh323 support
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 68c46dfef8d9..ac3606f4d8a0 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -15,7 +15,6 @@ COMMENT= Free C++ class library of Cryptographic Primitives
OPTIONS_DEFINE= DEBUG DOCS GCC STATIC THREADS
OPTIONS_DEFAULT= THREADS
STATIC_DESC= Build static version only (no shared libs)
-GCC_DESC= Build with current GCC
.include <bsd.port.options.mk>
diff --git a/www/mod_spdy/Makefile b/www/mod_spdy/Makefile
index bab25b1ff2e9..37451cbdd4f4 100644
--- a/www/mod_spdy/Makefile
+++ b/www/mod_spdy/Makefile
@@ -46,7 +46,6 @@ SUB_FILES+= mod_spdy.conf
SUB_LIST+= APACHEMODDIR=${APACHEMODDIR}
OPTIONS_DEFINE= GCC DEBUG
-GCC_DESC= Build with current GCC
.include <bsd.port.options.mk>