aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-01-30 21:44:44 +0800
committermat <mat@FreeBSD.org>2018-01-30 21:44:44 +0800
commit561f021f6b73a990bb3832e6c7e41f8335984f64 (patch)
tree4c2eba6381c8730ac6b2d7de8789be0589a6e64f
parentcd74ef5998c02b274a5a88e6c33fa6f111d7fbee (diff)
downloadfreebsd-ports-gnome-561f021f6b73a990bb3832e6c7e41f8335984f64.tar.gz
freebsd-ports-gnome-561f021f6b73a990bb3832e6c7e41f8335984f64.tar.zst
freebsd-ports-gnome-561f021f6b73a990bb3832e6c7e41f8335984f64.zip
Add a TCP_FASTOPEN option (default on) to allow not building it in. [1]
It is annoying because it outputs one line saying it cannot enable TCP_FASTOPEN when the deamon starts. While there, discover that FILTER_AAAA is always enabled in 9.12+ and no longer an option, so remove it. PR: 217288 [1] (based on) Reported by: doktornotor mailinator com Sponsored by: Absolight
-rw-r--r--dns/bind9-devel/Makefile12
-rw-r--r--dns/bind911/Makefile10
-rw-r--r--dns/bind912/Makefile12
3 files changed, 19 insertions, 15 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 9970186b4479..eeb23e3de72d 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= 0
.else
# dns/bind9xx here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= LOCAL/mat/bind
@@ -69,9 +69,9 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= *
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON TCP_FASTOPEN
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
- FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
+ FIXED_RRSET SIGCHASE IPV6 THREADS TCP_FASTOPEN
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -100,7 +100,6 @@ DLZ_MYSQL_DESC= DLZ MySQL driver (no threading)
DLZ_POSTGRESQL_DESC= DLZ Postgres driver
DLZ_STUB_DESC= DLZ stub driver
DNSTAP_DESC= Provides fast passive logging of DNS messages
-FILTER_AAAA_DESC= Enable filtering of AAAA records
FIXED_RRSET_DESC= Enable fixed rrset ordering
GEOIP_DESC= Allow geographically based ACL.
GOSTDEF_DESC= Enable GOST ciphers, needs SSL
@@ -122,6 +121,7 @@ RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
START_LATE_DESC= Start BIND late in the boot process (see help)
+TCP_FASTOPEN_DESC= RFC 7413 support
TUNING_LARGE_DESC= Tune named for large systems (**READ HELP**)
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
@@ -146,8 +146,6 @@ DNSTAP_IMPLIES= THREADS
DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
libprotobuf-c.so:devel/protobuf-c
-FILTER_AAAA_CONFIGURE_ENABLE= filter-aaaa
-
FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
GEOIP_CONFIGURE_WITH= geoip
@@ -213,6 +211,8 @@ START_LATE_SUB_LIST= NAMED_REQUIRE="SERVERS cleanvar" \
START_LATE_SUB_LIST_OFF=NAMED_REQUIRE="NETWORKING ldconfig syslogd" \
NAMED_BEFORE="SERVERS"
+TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
+
THREADS_CONFIGURE_ENABLE= threads
TUNING_LARGE_IMPLIES= THREADS
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 360ff183d8e8..0faad9b9b8a0 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 911
@@ -48,12 +48,12 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= *
OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON \
- DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP
+ DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP TCP_FASTOPEN
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA \
RPZ_NSIP RPZ_NSDNAME DOCS GEOIP \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
- START_LATE TUNING_LARGE
+ START_LATE TUNING_LARGE TCP_FASTOPEN
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -98,6 +98,7 @@ RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
START_LATE_DESC= Start BIND late in the boot process (see help)
+TCP_FASTOPEN_DESC= RFC 7413 support
TUNING_LARGE_DESC= Tune named for large systems (**READ HELP**)
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
@@ -222,6 +223,9 @@ post-patch-PORTREVISION-on:
${WRKSRC}/version
.endif
+post-patch-TCP_FASTOPEN-off:
+ @${REINPLACE_CMD} -e 's/#define ISC_PLATFORM_HAVETFO 1/#undef ISC_PLATFORM_HAVETFO/' ${WRKSRC}/configure
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mtree
${MKDIR} ${STAGEDIR}${ETCDIR}
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index 06d79ddc8fd1..db23a27f9cfd 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -8,7 +8,7 @@ PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
PORTREVISION= 0
.else
# dns/bind912 here
-PORTREVISION= 0
+PORTREVISION= 1
.endif
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
@@ -67,9 +67,9 @@ MAKE_JOBS_UNSAFE= yes
PORTDOCS= *
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON TCP_FASTOPEN
OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
- FIXED_RRSET SIGCHASE IPV6 THREADS FILTER_AAAA
+ FIXED_RRSET SIGCHASE IPV6 THREADS TCP_FASTOPEN
OPTIONS_RADIO= CRYPTO GOSTDEF
OPTIONS_RADIO_CRYPTO= SSL NATIVE_PKCS11
@@ -98,7 +98,6 @@ DLZ_MYSQL_DESC= DLZ MySQL driver (no threading)
DLZ_POSTGRESQL_DESC= DLZ Postgres driver
DLZ_STUB_DESC= DLZ stub driver
DNSTAP_DESC= Provides fast passive logging of DNS messages
-FILTER_AAAA_DESC= Enable filtering of AAAA records
FIXED_RRSET_DESC= Enable fixed rrset ordering
GEOIP_DESC= Allow geographically based ACL.
GOSTDEF_DESC= Enable GOST ciphers, needs SSL
@@ -120,6 +119,7 @@ RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
START_LATE_DESC= Start BIND late in the boot process (see help)
+TCP_FASTOPEN_DESC= RFC 7413 support
TUNING_LARGE_DESC= Tune named for large systems (**READ HELP**)
DLZ_BDB_CONFIGURE_ON= --with-dlz-bdb=yes
@@ -144,8 +144,6 @@ DNSTAP_IMPLIES= THREADS
DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
libprotobuf-c.so:devel/protobuf-c
-FILTER_AAAA_CONFIGURE_ENABLE= filter-aaaa
-
FIXED_RRSET_CONFIGURE_ENABLE= fixed-rrset
GEOIP_CONFIGURE_WITH= geoip
@@ -211,6 +209,8 @@ START_LATE_SUB_LIST= NAMED_REQUIRE="SERVERS cleanvar" \
START_LATE_SUB_LIST_OFF=NAMED_REQUIRE="NETWORKING ldconfig syslogd" \
NAMED_BEFORE="SERVERS"
+TCP_FASTOPEN_CONFIGURE_ENABLE= tcp-fastopen
+
THREADS_CONFIGURE_ENABLE= threads
TUNING_LARGE_IMPLIES= THREADS