aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2004-12-30 23:15:00 +0800
committerlth <lth@FreeBSD.org>2004-12-30 23:15:00 +0800
commit571fb8e3ae05b5164e2e961906dca8c845ee3a82 (patch)
treeded9ad22fb604976520ef976e7bb6e6a80509d5d
parent5c210b9048a1e7f93d387388e5b812c65d7bd6be (diff)
downloadfreebsd-ports-gnome-571fb8e3ae05b5164e2e961906dca8c845ee3a82.tar.gz
freebsd-ports-gnome-571fb8e3ae05b5164e2e961906dca8c845ee3a82.tar.zst
freebsd-ports-gnome-571fb8e3ae05b5164e2e961906dca8c845ee3a82.zip
Add p5-Email-FolderType-Net 1.02, recognize folder types for network
based message protocols.
-rw-r--r--mail/Makefile1
-rw-r--r--mail/p5-Email-FolderType-Net/Makefile26
-rw-r--r--mail/p5-Email-FolderType-Net/distinfo2
-rw-r--r--mail/p5-Email-FolderType-Net/pkg-descr5
-rw-r--r--mail/p5-Email-FolderType-Net/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 7608f6d85b50..fed0efde0f14 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -235,6 +235,7 @@
SUBDIR += p5-Email-Find
SUBDIR += p5-Email-Folder
SUBDIR += p5-Email-FolderType
+ SUBDIR += p5-Email-FolderType-Net
SUBDIR += p5-Email-LocalDelivery
SUBDIR += p5-Email-LocalDelivery-Ezmlm
SUBDIR += p5-Email-MIME
diff --git a/mail/p5-Email-FolderType-Net/Makefile b/mail/p5-Email-FolderType-Net/Makefile
new file mode 100644
index 000000000000..1d3e364e1028
--- /dev/null
+++ b/mail/p5-Email-FolderType-Net/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mail/p5-Email-FolderType-Net
+# Date created: 30 December 2004
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-FolderType-Net
+PORTVERSION= 1.02
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Recognize folder types for network based message protocols
+
+BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Email/FolderType/Register.pm:${PORTSDIR}/mail/p5-Email-FolderType
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::FolderType::Net.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-FolderType-Net/distinfo b/mail/p5-Email-FolderType-Net/distinfo
new file mode 100644
index 000000000000..b8f989cda024
--- /dev/null
+++ b/mail/p5-Email-FolderType-Net/distinfo
@@ -0,0 +1,2 @@
+MD5 (Email-FolderType-Net-1.02.tar.gz) = 7b4ab80e9e5d85c8bc10d7097dd5e07c
+SIZE (Email-FolderType-Net-1.02.tar.gz) = 1974
diff --git a/mail/p5-Email-FolderType-Net/pkg-descr b/mail/p5-Email-FolderType-Net/pkg-descr
new file mode 100644
index 000000000000..667e05dc4272
--- /dev/null
+++ b/mail/p5-Email-FolderType-Net/pkg-descr
@@ -0,0 +1,5 @@
+Registers several mail folder types that are known as network based
+messaging protocols. Folder names for these protocols should be
+specified using a URI syntax.
+
+WWW: http://search.cpan.org/dist/Email-FolderType-Net
diff --git a/mail/p5-Email-FolderType-Net/pkg-plist b/mail/p5-Email-FolderType-Net/pkg-plist
new file mode 100644
index 000000000000..5daa7dd29d7f
--- /dev/null
+++ b/mail/p5-Email-FolderType-Net/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Email/FolderType/Net.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType/Net/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType/Net
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/FolderType 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email/FolderType 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true