aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-19 00:16:49 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-19 00:16:49 +0800
commit582e943c615b210c7a1ddf5a1c3d46a9867d2fb9 (patch)
tree9bc2eb94c0cd8a5855ecdde515a1c185f95f7ff6
parenta4c4414c9fe6ff87cd0794330e844d077133a850 (diff)
downloadfreebsd-ports-gnome-582e943c615b210c7a1ddf5a1c3d46a9867d2fb9.tar.gz
freebsd-ports-gnome-582e943c615b210c7a1ddf5a1c3d46a9867d2fb9.tar.zst
freebsd-ports-gnome-582e943c615b210c7a1ddf5a1c3d46a9867d2fb9.zip
- Use USES=libtool
- Strip shared library in post-install: phase - Bump PORTREVISION for package change
-rw-r--r--archivers/librtfcomp/Makefile12
-rw-r--r--archivers/librtfcomp/pkg-plist1
2 files changed, 7 insertions, 6 deletions
diff --git a/archivers/librtfcomp/Makefile b/archivers/librtfcomp/Makefile
index 87361d732a14..9c07b2cb4117 100644
--- a/archivers/librtfcomp/Makefile
+++ b/archivers/librtfcomp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= librtfcomp
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= SF/synce/SynCE/${PORTNAME}
@@ -12,8 +13,8 @@ COMMENT?= Library for handling compressed RTF documents
LICENSE= LGPL21
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+USES= libtool
SLAVEDIRS= archivers/py-librtfcomp
@@ -28,16 +29,15 @@ post-patch:
@${REINPLACE_CMD} -e '/VISIBILITY=/ s| -fvisibility=hidden||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|$$(top_builddir)/src/librtfcomp.la|${LOCALBASE}/lib/librtfcomp.la|g' ${WRKSRC}/python/Makefile.in
-post-build:
-.if !defined(SLAVEPORT)
- @${STRIP_CMD} ${WRKSRC}/src/.libs/librtfcomp.so.0
-.endif
-
post-install:
.if !defined(SLAVEPORT)
${INSTALL_SCRIPT} ${WRKSRC}/tests/fromrtf ${STAGEDIR}${PREFIX}/bin/fromrtf
${INSTALL_SCRIPT} ${WRKSRC}/tests/test ${STAGEDIR}${PREFIX}/bin/testrtf
${INSTALL_SCRIPT} ${WRKSRC}/tests/tortf ${STAGEDIR}${PREFIX}/bin/tortf
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librtfcomp.so.0.0.0
+.endif
+.if defined(SLAVEPORT) && ${SLAVEPORT} == "py"
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pyrtfcomp.so
.endif
.include <bsd.port.mk>
diff --git a/archivers/librtfcomp/pkg-plist b/archivers/librtfcomp/pkg-plist
index d90f6da7e0eb..356878234646 100644
--- a/archivers/librtfcomp/pkg-plist
+++ b/archivers/librtfcomp/pkg-plist
@@ -7,4 +7,5 @@ lib/librtfcomp.a
lib/librtfcomp.la
lib/librtfcomp.so
lib/librtfcomp.so.0
+lib/librtfcomp.so.0.0.0
@dirrm include/rtfcomp