aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-05 02:12:39 +0800
committergerald <gerald@FreeBSD.org>2013-08-05 02:12:39 +0800
commit5a14643acad8a547bd6c5f0301a03dc2a956ce61 (patch)
tree347fe7bfb2b82603e44cc4ecc5ebe186a56eb603
parent78c009b5e342d18c6b5f3df64f2730fae6b45188 (diff)
downloadfreebsd-ports-gnome-5a14643acad8a547bd6c5f0301a03dc2a956ce61.tar.gz
freebsd-ports-gnome-5a14643acad8a547bd6c5f0301a03dc2a956ce61.tar.zst
freebsd-ports-gnome-5a14643acad8a547bd6c5f0301a03dc2a956ce61.zip
Update to the 20130728 snapshot of GCC 4.9.0.
Introduce a new option BOOTSTRAP that allows switching between a full bootstrap of GCC and just running a simple build. Bootstrapping is the default upstream, and for very stable and old flavors of GCC we disable this by default since that is a huge win in terms of build time of the port. No change in default behavior for this port -- for the time being we continue to bootstrap.
-rw-r--r--lang/gcc49/Makefile11
-rw-r--r--lang/gcc49/distinfo4
2 files changed, 11 insertions, 4 deletions
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index 8b4f21678d4e..daf83ae71509 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 4.9.0.20130630
+PORTVERSION= 4.9.0.20130728
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
@@ -38,10 +38,13 @@ MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
+OPTIONS_DEFINE= BOOTSTRAP
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
+OPTIONS_DEFAULT= BOOTSTRAP
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
@@ -62,6 +65,11 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
+.if empty(PORT_OPTIONS:MBOOTSTRAP)
+CONFIGURE_ARGS+=--disable-bootstrap
+.else
+ALL_TARGET= bootstrap-lean
+.endif
CONFIGURE_ARGS+=--disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
@@ -74,7 +82,6 @@ CONFIGURE_ARGS+=--disable-nls \
--with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
GNU_HOST=${CONFIGURE_TARGET} \
diff --git a/lang/gcc49/distinfo b/lang/gcc49/distinfo
index 492fe39ce540..29a7095453a1 100644
--- a/lang/gcc49/distinfo
+++ b/lang/gcc49/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcc-4.9-20130630.tar.bz2) = c25bbea86c196879e8e8af1227e47b255a7b3e842fbd69c72f6e0564ec4465df
-SIZE (gcc-4.9-20130630.tar.bz2) = 83093776
+SHA256 (gcc-4.9-20130728.tar.bz2) = f8630957ef498ec79594f5a0e35b6afed62ffa38331055388d0fc91d60773d19
+SIZE (gcc-4.9-20130728.tar.bz2) = 82415272