aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-04-20 16:11:27 +0800
committertcberner <tcberner@FreeBSD.org>2017-04-20 16:11:27 +0800
commit5cb27501ea12c4f30ec682ea9b19a54d98cbd2b9 (patch)
tree4b7d48bba9a2d041559116de0b3bf22fd4af6a76
parent447883358c408c2aa457408768e82058e0241017 (diff)
downloadfreebsd-ports-gnome-5cb27501ea12c4f30ec682ea9b19a54d98cbd2b9.tar.gz
freebsd-ports-gnome-5cb27501ea12c4f30ec682ea9b19a54d98cbd2b9.tar.zst
freebsd-ports-gnome-5cb27501ea12c4f30ec682ea9b19a54d98cbd2b9.zip
Add shebangfix.
Reported by: rezny Approved by: rakuco (mentor)
-rw-r--r--x11/kf5-kdelibs4support/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/x11/kf5-kdelibs4support/Makefile b/x11/kf5-kdelibs4support/Makefile
index 5731b352b269..57ddaaa9f690 100644
--- a/x11/kf5-kdelibs4support/Makefile
+++ b/x11/kf5-kdelibs4support/Makefile
@@ -3,6 +3,7 @@
PORTNAME= kdelibs4support
PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +11,8 @@ COMMENT= KF5 porting aid from KDELibs4
BUILD_DEPENDS= p5-URI>=0:net/p5-URI
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 shebangfix \
+ tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools globalaccel guiaddons \
i18n iconthemes itemviews jobwidgets kded kio notifications \
@@ -23,4 +25,6 @@ USE_QT5= buildtools_build core dbus designer gui network \
x11extras xml
USE_XORG= ice sm x11 xext
+SHEBANG_FILES= src/kio/fileshareset
+
.include <bsd.port.mk>