aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-04-13 09:04:08 +0800
committerglewis <glewis@FreeBSD.org>2002-04-13 09:04:08 +0800
commit5d44895874425e32f8dd17207ae906f116e1d897 (patch)
tree84883f83b753b7b209da7c92fc26b2cb0b56134e
parentd98d4c0e463f347d498704f45a17aff0d476b05f (diff)
downloadfreebsd-ports-gnome-5d44895874425e32f8dd17207ae906f116e1d897.tar.gz
freebsd-ports-gnome-5d44895874425e32f8dd17207ae906f116e1d897.tar.zst
freebsd-ports-gnome-5d44895874425e32f8dd17207ae906f116e1d897.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. This leaves 11 of the ports listed in the PR still to go. PR: 36411 Submitted by: Alan Eldridge <ports@geeksrus.net> Reviewed by: sobomax Approved by: sobomax
-rw-r--r--java/jdk12-beta/Makefile8
-rw-r--r--java/jdk12/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/java/jdk12-beta/Makefile b/java/jdk12-beta/Makefile
index 88cc8e6b120a..9e4341d67650 100644
--- a/java/jdk12-beta/Makefile
+++ b/java/jdk12-beta/Makefile
@@ -111,11 +111,11 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
- (cd ${JDKIMAGEDIR} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.if !defined(NODEBUG)
- (cd ${JDKIMAGEDIR_G} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR_G} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.endif
post-install:
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index 88cc8e6b120a..9e4341d67650 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -111,11 +111,11 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/jdk${JDK_VERSION}
- (cd ${JDKIMAGEDIR} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.if !defined(NODEBUG)
- (cd ${JDKIMAGEDIR_G} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jdk${JDK_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${JDKIMAGEDIR_G} && /usr/bin/find . \
+ | /usr/bin/cpio -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jdk${JDK_VERSION}
.endif
post-install: