aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-27 08:29:39 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-27 08:29:39 +0800
commit5d6160289b78445141cb8b73539233b1e9870b06 (patch)
treee7e34b75d55492fae208ff0bf8e651025024b183
parent663e4436e1ba24c806b40f03bd5e93e9d7c9c54a (diff)
downloadfreebsd-ports-gnome-5d6160289b78445141cb8b73539233b1e9870b06.tar.gz
freebsd-ports-gnome-5d6160289b78445141cb8b73539233b1e9870b06.tar.zst
freebsd-ports-gnome-5d6160289b78445141cb8b73539233b1e9870b06.zip
- Fix build against ports krb5
- Register dependencies correctly - Bump PORTREVISION PR: ports/149370 Submitted by: Benjamin Lee <ben@b1c1l1.com> With Hat: apache@
-rw-r--r--www/mod_auth_kerb2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index b6cb867e2535..4558f34e0a77 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -10,7 +10,7 @@
PORTNAME= mod_auth_kerb
PORTVERSION= 5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF/modauthkerb/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -28,14 +28,18 @@ GNU_CONFIGURE= yes
PORTSCOUT= limit:^5.3
-.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+.if defined(KRB5_HOME)
+BUILD_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
+RUN_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
-.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
+.elif defined(HEIMDAL_HOME)
+BUILD_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+RUN_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif