aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2016-06-07 00:42:44 +0800
committerzeising <zeising@FreeBSD.org>2016-06-07 00:42:44 +0800
commit5e2bebd30dde8c01006e8308e0d7d487ce2d63ec (patch)
tree13b863f3ae3ed5dc8b7164415598793ad5fa606b
parent6b83a6b33b89c70d1cf6df99e6fccd90defb3dbb (diff)
downloadfreebsd-ports-gnome-5e2bebd30dde8c01006e8308e0d7d487ce2d63ec.tar.gz
freebsd-ports-gnome-5e2bebd30dde8c01006e8308e0d7d487ce2d63ec.tar.zst
freebsd-ports-gnome-5e2bebd30dde8c01006e8308e0d7d487ce2d63ec.zip
Update to 3.0.2
This makes spectrwm support ICCCM and EWHM. PR: 209965 Submitted by: Oleg Gushchenkov
-rw-r--r--x11-wm/spectrwm/Makefile10
-rw-r--r--x11-wm/spectrwm/distinfo4
-rw-r--r--x11-wm/spectrwm/files/patch-freebsd_util.h39
-rw-r--r--x11-wm/spectrwm/files/patch-spectrwm.c6
-rw-r--r--x11-wm/spectrwm/files/patch-spectrwm.conf25
5 files changed, 11 insertions, 73 deletions
diff --git a/x11-wm/spectrwm/Makefile b/x11-wm/spectrwm/Makefile
index 74c0bbc9edb1..94ac3885d5c1 100644
--- a/x11-wm/spectrwm/Makefile
+++ b/x11-wm/spectrwm/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= spectrwm
-PORTVERSION= 2.7.2
+PORTVERSION= 3.0.2
CATEGORIES= x11-wm
-MASTER_SITES= https://opensource.conformal.com/snapshots/${PORTNAME}/
-EXTRACT_SUFX= .tgz
MAINTAINER= zeising@FreeBSD.org
COMMENT= Small, dynamic tiling window manager for X11
@@ -17,6 +15,10 @@ LIB_DEPENDS+= libxcb-util.so:x11/xcb-util \
libxcb-keysyms.so:x11/xcb-util-keysyms
RUN_DEPENDS+= dmenu:x11/dmenu
+USE_GITHUB= yes
+GH_ACCOUNT= conformal
+GH_TAGNAME= SPECTRWM_3_0_2
+
USE_XORG= x11 xcb xcursor xft xrandr xt
USE_LDCONFIG= yes
@@ -35,7 +37,7 @@ do-build:
-I${LOCALBASE}/include/freetype2 -I${WRKSRC}/freebsd \
-lutil -L${LOCALBASE}/lib -lX11 -lX11-xcb -lxcb -lxcb-icccm \
-lxcb-keysyms -lxcb-randr -lxcb-util -lxcb-xtest -lXcursor \
- -lXft -lXrandr -DSWM_LIB=\"${PREFIX}/lib/libswmhack.so\" \
+ -lXft -DSWM_LIB=\"${PREFIX}/lib/libswmhack.so\" \
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.c
${CC} ${CFLAGS} -I${LOCALBASE}/include -shared -fpic -DPIC \
-o ${WRKSRC}/libswmhack.so ${WRKSRC}/lib/swm_hack.c
diff --git a/x11-wm/spectrwm/distinfo b/x11-wm/spectrwm/distinfo
index b7ecde6d5390..661856fd9286 100644
--- a/x11-wm/spectrwm/distinfo
+++ b/x11-wm/spectrwm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (spectrwm-2.7.2.tgz) = b56cffa01ee2c58515350c1be1940140286fd18778659c6f5ada4595319f97cb
-SIZE (spectrwm-2.7.2.tgz) = 132554
+SHA256 (conformal-spectrwm-3.0.2-SPECTRWM_3_0_2_GH0.tar.gz) = 82ce0280039de642c41684f3096abb0388926b60c37987ca1dbc53a0913cab18
+SIZE (conformal-spectrwm-3.0.2-SPECTRWM_3_0_2_GH0.tar.gz) = 147355
diff --git a/x11-wm/spectrwm/files/patch-freebsd_util.h b/x11-wm/spectrwm/files/patch-freebsd_util.h
deleted file mode 100644
index 9962a37c06c2..000000000000
--- a/x11-wm/spectrwm/files/patch-freebsd_util.h
+++ /dev/null
@@ -1,39 +0,0 @@
-From 0e4d41f065f7803d096e6c53b3956c820186c3ea Mon Sep 17 00:00:00 2001
-From: Reginald Kennedy <rk@rejii.com>
-Date: Sun, 31 May 2015 07:25:46 +0800
-Subject: [PATCH] Add SIMPLEQ->STAILQ macros for freebsd.
-
----
- freebsd/util.h | 18 +++++++++++++++++-
- 1 files changed, 17 insertions(+), 1 deletions(-)
-
-diff --git a/freebsd/util.h b/freebsd/util.h
-index 4737d42..34b5c36 100644
---- freebsd/util.h
-+++ freebsd/util.h
-@@ -1,5 +1,21 @@
- #include <libutil.h>
-
- #ifndef TAILQ_END
--#define TAILQ_END(head) NULL
-+#define TAILQ_END(head) NULL
-+#endif
-+
-+#ifndef SIMPLEQ_HEAD
-+#define SIMPLEQ_HEAD STAILQ_HEAD
-+#define SIMPLEQ_HEAD_INITIALIZER STAILQ_HEAD_INITIALIZER
-+#define SIMPLEQ_ENTRY STAILQ_ENTRY
-+#define SIMPLEQ_INIT STAILQ_INIT
-+#define SIMPLEQ_INSERT_AFTER STAILQ_INSERT_AFTER
-+#define SIMPLEQ_INSERT_HEAD STAILQ_INSERT_HEAD
-+#define SIMPLEQ_INSERT_TAIL STAILQ_INSERT_TAIL
-+#define SIMPLEQ_EMPTY STAILQ_EMPTY
-+#define SIMPLEQ_FIRST STAILQ_FIRST
-+#define SIMPLEQ_REMOVE_AFTER STAILQ_REMOVE_AFTER
-+#define SIMPLEQ_REMOVE_HEAD STAILQ_REMOVE_HEAD
-+#define SIMPLEQ_FOREACH STAILQ_FOREACH
-+#define SIMPLEQ_END(head) NULL
- #endif
---
-1.7.6
-
diff --git a/x11-wm/spectrwm/files/patch-spectrwm.c b/x11-wm/spectrwm/files/patch-spectrwm.c
index 342a9aefc435..5640a7b57450 100644
--- a/x11-wm/spectrwm/files/patch-spectrwm.c
+++ b/x11-wm/spectrwm/files/patch-spectrwm.c
@@ -1,6 +1,6 @@
---- spectrwm.c.orig 2014-04-06 09:43:33.000000000 +0200
-+++ spectrwm.c 2014-04-06 09:43:33.000000000 +0200
-@@ -7008,7 +7008,7 @@
+--- spectrwm.c.orig 2016-06-05 07:12:06 UTC
++++ spectrwm.c
+@@ -7876,7 +7876,7 @@ validate_spawns(void)
void
setup_spawn(void)
{
diff --git a/x11-wm/spectrwm/files/patch-spectrwm.conf b/x11-wm/spectrwm/files/patch-spectrwm.conf
deleted file mode 100644
index c4be7da19625..000000000000
--- a/x11-wm/spectrwm/files/patch-spectrwm.conf
+++ /dev/null
@@ -1,25 +0,0 @@
-From e4d823fc43527b676f631d72cc2cfd22254b15ff Mon Sep 17 00:00:00 2001
-From: Reginald Kennedy <rk@rejii.com>
-Date: Sat, 4 Jul 2015 13:24:24 +0800
-Subject: [PATCH] Fix spectrwm.conf unbind example.
-
----
- spectrwm.conf | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/spectrwm.conf b/spectrwm.conf
-index 35948ef..2302580 100644
---- spectrwm.conf
-+++ spectrwm.conf
-@@ -92,7 +92,7 @@
-
- # To disable validation of the above, free the respective binding(s):
- # bind[] = MOD+Shift+Delete # disable lock
--# bind[] = MOD+Shift+Enter # disable term
-+# bind[] = MOD+Shift+Return # disable term
- # bind[] = MOD+p # disable menu
-
- # Optional default programs that will only be validated if you override:
---
-1.7.6
-