aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2013-08-31 09:51:02 +0800
committerbdrewery <bdrewery@FreeBSD.org>2013-08-31 09:51:02 +0800
commit5f5e698e023c9c1f60998f91f71131fdae298bc5 (patch)
tree37f1d7f8ef86ff5e79518ef512924f87d7bf811d
parenteb86d7e748ad1a056e903a36fed3e940f79e04a0 (diff)
downloadfreebsd-ports-gnome-5f5e698e023c9c1f60998f91f71131fdae298bc5.tar.gz
freebsd-ports-gnome-5f5e698e023c9c1f60998f91f71131fdae298bc5.tar.zst
freebsd-ports-gnome-5f5e698e023c9c1f60998f91f71131fdae298bc5.zip
- IGNORE when PACKAGE_BUILDING as these require manual fetch
With hat: portmgr
-rw-r--r--databases/datamodeler/Makefile12
-rw-r--r--databases/msql/Makefile6
-rw-r--r--net/vmware-vsphere-cli/Makefile12
-rw-r--r--security/truecrypt/Makefile6
4 files changed, 22 insertions, 14 deletions
diff --git a/databases/datamodeler/Makefile b/databases/datamodeler/Makefile
index bb70625225df..3448f42d837a 100644
--- a/databases/datamodeler/Makefile
+++ b/databases/datamodeler/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: datamodeler
-# Date created: 22 October 2011
-# Whom: jjuanino@gmail.com
-#
+# Created by: jjuanino@gmail.com
# $FreeBSD$
-#
PORTNAME= datamodeler
PORTVERSION= 3.1.0.700
@@ -57,11 +53,15 @@ DISTFILE_INSTRUCTIONS += into ${DISTDIR}/${DIST_SUBDIR}/ \n
DISTFILE_INSTRUCTIONS += and then restart this installation\n\n
.endif
-pre-fetch:
.if defined(DISTFILE_INSTRUCTIONS)
+.if defined(PACKAGE_BUILDING)
+IGNORE= requires manual fetch
+.else
+pre-fetch:
@${PRINTF} "${DISTFILE_INSTRUCTIONS}"
@exit 1
.endif
+.endif
SUB_FILES= ${PORTNAME}.script.sh
SUB_LIST= JAVA_HOME=${JAVA_HOME}
diff --git a/databases/msql/Makefile b/databases/msql/Makefile
index f4f542da99df..4fc117af598c 100644
--- a/databases/msql/Makefile
+++ b/databases/msql/Makefile
@@ -77,10 +77,14 @@ and place it in ${DISTDIR}.\n\
The distribution requires registration prior to use.\n\n
.endif
-pre-fetch:
.if defined(DISTFILE_INSTRUCTIONS)
+.if defined(PACKAGE_BUILDING)
+IGNORE= requires manual fetch
+.else
+pre-fetch:
@${PRINTF} "${DISTFILE_INSTRUCTIONS}"
@exit 1
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/net/vmware-vsphere-cli/Makefile b/net/vmware-vsphere-cli/Makefile
index 056fec6037dd..feca24bf6a0b 100644
--- a/net/vmware-vsphere-cli/Makefile
+++ b/net/vmware-vsphere-cli/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vmware-vsphere-cli
-# Date created: 2011-07-07
-# Whom: rpsfa@rit.edu
-#
+# Created by: rpsfa@rit.edu
# $FreeBSD$
-#
PORTNAME= vmware-vsphere-cli
PORTVERSION= 5.1.0
@@ -49,11 +45,15 @@ After the download has completed, please place ${DISTNAME}${EXTRACT_SUFX} in\n\
${DISTDIR}, then restart the build.\n\n
.endif
-pre-fetch:
.if defined(DISTFILE_INSTRUCTIONS)
+.if defined(PACKAGE_BUILDING)
+IGNORE= requires manual fetch
+.else
+pre-fetch:
@${PRINTF} "${DISTFILE_INSTRUCTIONS}"
@exit 1
.endif
+.endif
post-extract:
@${MV} ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-distrib ${WRKSRC}
diff --git a/security/truecrypt/Makefile b/security/truecrypt/Makefile
index a0b035bd28a3..e59ce4afc425 100644
--- a/security/truecrypt/Makefile
+++ b/security/truecrypt/Makefile
@@ -63,11 +63,15 @@ Place the downloaded file into ${DISTDIR} and rename it to ${TC_SRCFILE}\n\n\
Then, please restart the build.\n\n
.endif
-pre-fetch:
.if defined(DISTFILE_INSTRUCTIONS)
+.if defined(PACKAGE_BUILDING)
+IGNORE= requires manual fetch
+.else
+pre-fetch:
@${PRINTF} "${DISTFILE_INSTRUCTIONS}"
@exit 1
.endif
+.endif
do-build:
@${MKDIR} ${WRKDIR}/rsa