aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2007-06-11 17:11:46 +0800
committerleeym <leeym@FreeBSD.org>2007-06-11 17:11:46 +0800
commit5f8b0c0bf7858ef45b2331beeea70b422251dc7b (patch)
treef1c1b4b5ed057de7ed7ecf7cbc7f2dff49cb1088
parent8d39955f8248e0f80ed30573b91f79d4e01f9b66 (diff)
downloadfreebsd-ports-gnome-5f8b0c0bf7858ef45b2331beeea70b422251dc7b.tar.gz
freebsd-ports-gnome-5f8b0c0bf7858ef45b2331beeea70b422251dc7b.tar.zst
freebsd-ports-gnome-5f8b0c0bf7858ef45b2331beeea70b422251dc7b.zip
- add Crypt::OpenSSL::X509 0.5
This implement a large majority of OpenSSL's useful X509 API. The email() method supports both certificates where the subject is of the form: "... CN=Firstname lastname/emailAddress=user@domain", and also certificates where there is a X509v3 Extension of the form "X509v3 Subject Alternative Name: email=user@domain". Submitted by: kftseng@iyard.org
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-OpenSSL-X509/Makefile24
-rw-r--r--security/p5-Crypt-OpenSSL-X509/distinfo3
-rw-r--r--security/p5-Crypt-OpenSSL-X509/pkg-descr9
-rw-r--r--security/p5-Crypt-OpenSSL-X509/pkg-plist10
5 files changed, 47 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index db6e65422a00..d1b4dcf8e5cf 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -390,6 +390,7 @@
SUBDIR += p5-Crypt-OpenSSL-DSA
SUBDIR += p5-Crypt-OpenSSL-RSA
SUBDIR += p5-Crypt-OpenSSL-Random
+ SUBDIR += p5-Crypt-OpenSSL-X509
SUBDIR += p5-Crypt-PGPSimple
SUBDIR += p5-Crypt-PassGen
SUBDIR += p5-Crypt-PasswdMD5
diff --git a/security/p5-Crypt-OpenSSL-X509/Makefile b/security/p5-Crypt-OpenSSL-X509/Makefile
new file mode 100644
index 000000000000..822f60af4330
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-X509/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Crypt-OpenSSL-X509
+# Date created: 2007/06/09
+# Whom: kftseng@iyard.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-OpenSSL-X509
+PORTVERSION= 0.5
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kftseng@iyard.org
+COMMENT= Perl extension for OpenSSL X509 API
+
+BUILD_DEPENDS= ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::OpenSSL::X509.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-X509/distinfo b/security/p5-Crypt-OpenSSL-X509/distinfo
new file mode 100644
index 000000000000..2fc05a202674
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-X509/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-OpenSSL-X509-0.5.tar.gz) = b32d1e07d851a6e44beb7aec732f25a3
+SHA256 (Crypt-OpenSSL-X509-0.5.tar.gz) = e6c1cb153505655498d1b418032354a5efd9c7252050b8af175044224800e985
+SIZE (Crypt-OpenSSL-X509-0.5.tar.gz) = 6904
diff --git a/security/p5-Crypt-OpenSSL-X509/pkg-descr b/security/p5-Crypt-OpenSSL-X509/pkg-descr
new file mode 100644
index 000000000000..be26db546195
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-X509/pkg-descr
@@ -0,0 +1,9 @@
+This implement a large majority of OpenSSL's useful X509 API.
+
+ The email() method supports both certificates where the
+ subject is of the form:
+ "... CN=Firstname lastname/emailAddress=user@domain", and also
+ certificates where there is a X509v3 Extension of the form
+ "X509v3 Subject Alternative Name: email=user@domain".
+
+WWW: http://search.cpan.org/dist/Crypt-OpenSSL-X509/
diff --git a/security/p5-Crypt-OpenSSL-X509/pkg-plist b/security/p5-Crypt-OpenSSL-X509/pkg-plist
new file mode 100644
index 000000000000..25c83fc6411e
--- /dev/null
+++ b/security/p5-Crypt-OpenSSL-X509/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL/X509.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/X509/X509.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/X509/X509.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/X509/.packlist
+
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL/X509
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/OpenSSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt